File explorer opens upon WD Security unlock


I notice when you unlock a WD drive from WD Security it opens file (windows) explorer. I have it set to auto unlock when my computer starts up. After it auto unlocks, it opens file explorer. I don’t want to see that every time I start my computer.

Is there any way to stop file explorer from opening when you use WD Security to unlock a drive (regardless if it’s manual or auto)?


Hello there,

Under settings, you will see the devices section, on this section you will see auto play. I believe you can set that up on that section, hope this helps.

Thank you for your reply. Would this be the settings in WD Security or WD SmartWare Pro? I don’t see a settings section in WD Security. In SmartWare settings, I only see: File History, Retrieve Folder, Software Updates, and Dropbox Account.

Btw, WD Security is version WD SmartWare Pro is version 2.4.12.


I would like to know if and how the File Explorer opening problem has been solved. I am operating with Windows 10 and have installed WD Passport Ultra 1 TB. WD Security,Utilities, and Backup all install in the Startup menu and when a password is set with WD Security the File Explorer opens when the computer is turned on. If the password is removed, then the normal Desktop opens when computer is turned on. The opening of File Explorer when a password is used is not a major problem. It is more a nuisance. Is there any way to stop File Explorer from opening when a password is used?