File execute permission for executable uploaded over the cloud


I had uploaded some executable files using the mycloud desktop app when I was outside. However when reaching home and browsing to the folder via windows explorer, I’m unable to execute the file directly from the share. The file doesn’t seem to have execute permissions. I get the error, "You do not have permission to access \<share name>/abc.exe

I’ve tried changing the share from public to private with password but still get the same error. Am I doing something wrong here or is there no way to upload executables via the cloud app and later execute directly from the file share ?

Executable files copied/uploaded using windows file share directly run fine directly from the share drive.

I hope to avoid having to copy the file to my local drive just to run it. Any help appreciated.

Welcome to the Community.

Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support



Hi, we have passed this along to support.

Hi Has there been a solution to this issue?