File access issues

I bought last November WD My Book 3Tb.

It worked very well up until recently. When I make mp3 and mp4 from my collection and copy files to the WD drive or when I just genuinly download videos or music from Dropbox or Email. I can open files on the PC but when I copy them to the iPod Touch or iPad, Itunes and whole PC freezes and just wouldn’t copy them.

When I use Iogear Wireless Storage Manager to access them, the Iogear manager says that file is corrupt or the error in accessing the file, however again, I can use any other drive with Iogear (and same files) and it works and I can def open those files from WD My Book on PC.

Has anybody run into the same issue like this by any chance?

When I called the support ~3-4 times, very “helpful” support techs kept bouncing me citing that since it works on the PC, they don’t cover 3rd party access.

Please help!

Hello and welcome to the WD Community.

Have you tried testing the drive using the DLG tool? If yes, what are the results.

If not, see the following link for assistance.

1 Like

Thanks for the reply, I will try it later tonight and will let you know if there’s still a problem.

I have tried the WD scan few days ago but it says all passed.

Like I mentioned to one of the tech on the phone, it doesn’t happen all the time and pretty sporadic.

I can copy them to my iPod and iPad as of yesterday but still can’t view them via my iogear wireless storage device, keeps saying that it can’t read the file.

WD support team has contacted me directly, hopefully I will be able to get a solution with the phone call tomorrow.

Thanks guys for help.