Favorited Folder now "No Media In Current Folder"

So now what’s wrong with this thing?

I have a Favorited folder on a My Book on my network… worked fine for months and now all of a sudden when I select that favorite I get a “There is no media in the current folder” message…

What has this thing done to itself now

Did anything change in the setup ( firmware/security/router/connections ) ?

Not a thing… Turned it off to go to bed… when I turned it back on the next day, “No Media Blah Blah Blah”

A few suggestions…

Try Options> Rescan (you may have to do this twice to be sure of results).

Try rebuilding the Media Library.

Try power cycling the machine.

How about WHY would this happen in the first place?

What’s broken about the WD Hub that it forgets such seemingly intrinsic functionality…

And what if anything is WD doing to fix it…

“Hello, Western Digital. Have you tried turning it off and on again?” should only ever be a joke… Not an accepted solution…

When the WD went to check the server that contained the favorite, the server wasn’t available.  

The WD will then drop the connection to the server because it’s unreachable.

It will not reconnect until you restore the service and reboot the WD to restore the connection.

It’s not WD’s issue to fix.  If you don’t want the WD to do that, then make sure your shares remain up whenever the WD is on or in standby.

Make sure my shares are up?

So my WD MyBook can’t ever “sleep” because my WD hub might sometimes be able to find it and sometimes not? It can work for weeks or months at a go, but then for no good reason just stop working and it can’t reconnect without being completely rebooted?

That sure sounds to me like a failing on WD’s part with at least one device or another… or both…

No, that’s just how networking works. Sometimes a machine needs a whack to start working again…

Funny how nothing else in my network seems to ever need such a whack… At least not since the… late 90’s or so…

TonyPh12345 is correct

if the server becomes unreachable the connection is dropped

once the server is up again, you must reconnect

this is basic networking 101 for any network device

could be the router, could be, you turned off the desktop/machine sharing the drive

could be that you actually shut down the WD, instead of putting it on standby

remember these new units, if you hold the power button for 5 seconds, they actually turn off, instead of going into standby

TonyPH12345 may be correct, but it doesn’t answer why it happened.

The router didn’t change at all…
The drive is network attached storage so there’s no desktop or machine to turn off.
I haven’t touched the power button on The Hub for weeks… With my Harmony Remote set to always put it in Stand By (because making two different “commands” for Sleep vs Stand By is apparently rocket science) I’ve no need of the physical button on The Hub.

So, nope, nope, and, nope.

Seems like the answer is looking to be either “Nobody knows.” (which seems woefully inadequate) or “Nobody will admit to why.”… Which seems… Well… You know.

You can make a custom button on the Harmony to send the IR for 5 seconds. Works fine on my 880. One button labeled Stndby and another labeled Power DWN. 

Which, while interesting, has nothing to do with the issue at hand.

But to a Transformer Prime user from a Transformer Infinity user, cheers!

you touch the power button everytime you power up/down, even if using the harmony to power up/down

the harmony remote is just sending the same commands

I’d guess it’s the harmony remote

I’ve got a harmony one

are you using the default profile for WDTV Hub

default power down profile is to turn the device off, by sending the power signal for 5 seconds

and even if it’s none of this, basic networking still applies

the WD periodically sends out packets

to check if the server is still available

if it does not receive a response the connection is terminated

and yes this happens even when in standby

it could be as basic as a dropped back by either the router, a switch or the WD

due to network interferance or other network issues

My Harmony Remote only ever puts my Hub in standby

the why, is not important if it’s a one time issue

for a one time issue, the possibilities of why the WD did not receive an Acknowledgment packet could be anything

you’ve got following devices




harmony remote

all of which could have had a 1 time temporary issue

if it becomes a re-occuring issue

then you’ll need to start inspecting log files to find out what happened

short of comparing log files on each device, nobody can tell you why it happened