'[FAQ] Twonky DLNA Media Server Setup & Use

It appears, but I could be wrong, the Online Services portion is being populated from Twonky.com and not internal to the My Cloud.

There is a Twonky media server user forum at the following link: http://www.twonkyforum.com/viewforum.php?f=2

Doing a forum search for “Online Services” brings up a few hits including one indicating an Online Services setting in the Twonky.ini file.

Edit: The Twonkyserver.ini file is located in the /CacheVolume/twonkymedia directory.

The twoinkyforum.com link to a post has the following in their INI file.

# URL to a web application for the online services configuration

In the twonkyserver.ini file on my v4.x My Cloud that entry is:

# URL to a web application for the online services configuration

Changing that entry to “http://profile.twonky.com” on the My Cloud made no difference after restarting the Twonky server.

Edit: For what ever reason the My Cloud upon unit reboot is changing “profileserviceurl=” value back to profileserviceurl= after I make the change to profileserviceurl=http://profile.twonky.com.

If one’s purpose for the MyCloud drive is to solely have a network drive, then I would turn “OFF” all media server options. I found it “significantly” slows down MyCloud drive access.

Yes, turning off the Media Serving option may potentially speed up My Cloud access. However, the fact that one is reading this thread, it is a good indication they WANT to use the media serving option. :wink:

There are a variety of suggestions in the OP post of this thread that may help eliminate or reduce problems with the Twonky Media Server that is embedded within the My Cloud.

Thanks Bennor. Wasn’t trying to hijack the conversation. But I have had various issues since the last firmware update…

Thanks Bennor. After hours with WD Support (not really a support) . Unfortunately I have to say that it looks like they have no idea about their own product. The first answer from WD support was: “We would recommend that you Turn On the Twonky Media feature. You’ll be able to do this by accessing the unit’s dashboard, clicking on Media and turning the DLNA server on.” Well, thanks! That is what is done by default and is not the question. The next level of support declined that this function is available because WD My Cloud is running as a DLNA server only. This is simply wrong. You can by default configuration aggregate all media files in your network to WD My Cloud, index and stream them or decide to duplicate them into WD My Cloud. Plus the “Online Services” function is activated by default. I guess the setup is not correct. Support promised to call me back, but didn’t; support promised to escalate to next service level but didn’t and keep on going to say: “You will see that on the link you provided are the steps to access the Twonky user interface, but the option to enable 3rd party services is not available.” Good by WD My Cloud?

1 Like

Update: believe it or not after hours with Support I figured out that Twonky has discontinued myTwonky some time ago (more than three years now). ON top of this I was informed by Twonky that they discontinue the Online Services. In this version the option is already turned off by default. It can be turned on again by changing the ini-file. Set “disablemytwonky=0” and the Online Services are back. However, in one of the next versions this feature will be completely gone. So for me it looks like the WD default configuration and the WD online documention is not up to date and wrong. That said, this limited the functions of WD MyCloud.

1 Like

now it’s becoming kind of funny: got a call from WD Support telling me that WD MyCloud is for storage only and streaming some media to the TV. ok guys, read this thread and others and get be better educated. My apologize if this sounds rude but the answer on my question if other WD MyCloud (like Mirror) deliver what I’m looking for was: you can use WD MyCloud and use another device that is delivering what you want (I mentioned to potentially switch to a Synology NAS).

No need to apologise to us; we entirely share your thoughts about WD’s poor attitude to supporting an advertised feature of their product.

1 Like

Post edit, miss read the MyTwonky.

In any event Twonky server is up to version 8.2 released last November. And is up to 8.2.1 which was released on February 8, 2016. What I assume is happening is WD paid for a certain license (several year old) and hasn’t paid for the newest/latest licensed version of Twonky. It appears the version in the latest v4.x firmware is 7.2.9 which was released late 2014. One can see more information in the Twonky Release Notes: https://docs.twonky.com/display/TRN/Twonky+Release+Notes

One can peruse the Twonky support forum to see specific posts about Twonky: http://www.twonkyforum.com/

The problem with calling WD Support, really almost any large tech company’s phone support, is the phone support people often don’t know the full details about the product they are supporting. Often they are reading from a prepared script of answers to common questions and issues. Often the phone support people don’t know what the developers are doing to the firmware or know the details of the firmware or the many complains about a product in the user to user product support forums such as this one.

The Twonky media server on the My Cloud (using Twonky media server firmware that is two years old now) generally works for most as a very basic media server provided one doesn’t look for advanced features. Where people typically run into problems is with the Media Receivers not listing their device properly or their device not properly displaying media content served up by Twonky. There is also the issue of what appears to be poor integration between the My Cloud OS and Twonky that appears to cause certain issues. Obviously with the media server firmware being two years old it doesn’t have the latest capabilities and fixes of the latest Twonky firmware.

1 Like

If the facilities that are apparently available from the UI of the Twonky server aren’t actually available, it’s just another example of how Twonky is just plonked onto the MyCloud, without any attempt to integrate it properly.

I’m sure it wouldn’t be that difficult to turn off features that are now obsolete. But it seems, once again, that WD simply can’t be bothered to support their product properly.

1 Like

“the final cut” with WD: I ordered a Synology NAS

1 Like

Having updated my firmware (accidentally, through the mobile app…), I discovered that the new firmware had modified the sharing and public access settings of some of my shares (not happy about that). *

So I stupidly used the Dashboard to turn off media serving on two shares that don’t have media on them (or, that I don’t want media to be shared).

But I forgot that doing so causes the MyCloud to overwrite /etc/contentdir, killing my nice, fine-grained media searching controls, and setting the search back to ‘All Content Types’.

I found out when I tried to use a playlist, which refused to play, which led me to look at my library, and discover it was completely wrong.

It was interesting, having correcting the ‘Sharing’ control in the Twonky UI, to watch the content status count down, as it removed to old search tree from its database, and then ramp up again as it searched the new…

* Oh, and it set my access to my private share to ‘none’. Not happy about that, either…

I have a suggestion for twonkyserver.ini. This probably will not survive an upgrade, but there are many other frustrating ways for the .ini file to be overwritten.

In /usr/local/twonkymedia-7 the twonky executable files live. There are also two .ini precursor files: twonkyserver-default.ini and twonkyserver-default.ini.orig. I have an extra directory in /Public that I want kept out of the DLNA scan. The .ini files both contain an “ignoredir” environment variable setting. I have added the directory I’m interested in to the front of this variable.

twonkyserver-default.ini contains more settings than the .orig file, including “freindlyname” which is currently set to the value “%HOSTNAME%”. That is, it’s set to a Windows variable expansion. It’s running in a linux environment, so that is not going to work. You will have noticed that, when you first access the twonky setup UI, the @HOSTNAME@ appears as the default. Try changing it to $HOSTNAME. This will only work if the process that restores the twonkyserver.ini file expands the variables in the context of a linux shell, but it’s no worse than a Windows variable expansion.

I have made these changes myself, but have yet to test them. Everything’s working at the moment, and I’m not going to reboot or restart media serving until I have to. If anyone else tests this before I get around to it, please let me know.

One strange feature I notice also is the following: If I change the name of a file inside a folder in the WD MyCloud dashboard /apps /Web File Viewer, this file DOES NOT change name inside Twonky server identical folder ! How is that possible ???

It depends on what you are viewing as the ‘file name’.

If you use the DLNA ‘By Folder’ physical library view, it should reflect the change in file name (assuming Twonky has re-scanned the library).

If you view by any of the metadata logical library views, then you will see the metadata name (the tag, stored inside the file), rather than the actual filename. Changing the filename does not change the metadata tags.

It’s important to understand the distinction between physical library structure (the actual folder names and file names on the disk) and the logical library structure (based on the metadata tags within the files). The only DLNA ‘view’ that gives the physical library structure is ‘By Folder’.

Thanks but …euh ! Sounds like chinese to me. By the way I found that the rescan and rebuild buttons in the dashboard panel settings/media/DLNA Media server are missing ???

Go and read up about media file metadata, then. Google is your (tax avoiding) friend.

Do you have a Gen2 hardware / v2 firmware MyCloud?

Great stuff for a rookie - but one issue I can´t find despite long read, is how to correct Media-Data once it was ripped. Eg. correct typos, change Music style, etc
I use WMP (because it´s installed and works) but trying to do such changes after ripping, it failes. The [Edit] function simply is greyed out - I assume there is an access issue, but don´t know where exactly.
A minor question is about the format of multiple entries for artists, composer, music styles …
eg. if you have a Title1 by Artist1 and another Title2 by Artist1 and Artist2 my Media Client won´t show Title1 and Title2 under Artist1 - I tried different separators , ; / but none of them worked.

Any hint much appreciated

One can use any number of free and paid metadata editors to fix, change or add metadata to media files. Two popular ones are Media Monkey (http://www.mediamonkey.com) and MP3Tag (http://www.mp3tag.de).

Artist, Album Artist, Album Title, Title are all distinct metadata tags. Nb. metadata tags are embedded in the file, and are different from the filename.

Not all file formats support sophisticated metadata; WAV, in particular, is very poor. If you want lossless ripping, use FLAC, not WAV.

If your ripper does not allow you to modify metadata, find a better ripper (e.g. Exact Audio Copy. or MediaMonkey), or use a metadata editor (such as MP3Tag).I didn’t like WMP as a ripper, because it often left unidentified albums or tracks (“Unknown Album yy-mm-dd”). And it’s not good for ripping to FLAC.

If your media client doesn’t allow you to choose which metadata tags to display and sort files by, use a better media client (e.g. MediaMonkey, MusicBee). A good media client also acts as a media library manager, allowing you to modify tags, etc.