Fails everytime to copy bunch of files from EX2 to pc

#1

Since my clean install to Windows 10 I always get this annoying problem. In Windows 7 this never happened.

Windows 10 64 bit activated.
WD MyCloud EX2 connected Gigabit.
EX2 recognized in network and mapped as network drive in This PC

When I try to copy a folder with files in it (+/- 3GB), it stops in the middle of the process, giving the error shown in attachment. I tested with a folder of mp3s, pictures and videos, all the same result.
I looked on the web for possible causes and solutions and tried everything:

  • Network is set to Private
  • Played with the advanced sharing settings in Windows
  • Disabled antivirus / firewall (Windows and router)
  • Enabled NetBios in network adapter settings
  • Tried SMB1, SMB2, SMB3 settings in EX2 dashboard
  • Reboot router, EX2
  • Added login details to Windows Credentials
  • Basically everything mentioned here: Compilation of Windows 10 Methods, Steps and Solutions

Can anyone explain me what’s going on, tell me what the problem is or point me to a fix, please?

#2

Just noticed this:

  • Problem does not occur when transferring ONE big file (+3GB)
  • When the copy is “stuck”, browsing, opening maps in windows explorer on the EX2 seems to activate it again.
    Then it stalls after a second or two.
#3

Looks like that some of your Windows System DLLs are corrupt:

more general:
https://support.microsoft.com/en-us/kb/2649905

with some suggestions and hopefully helpful:
http://answers.microsoft.com/en-us/windows/forum/windows_8-update/error-code-0x8007002-and-0x8007003/6fa3c07d-897b-4945-8714-1385934b1d48

#4

Thank you for your answer and suggestions.
This is a 2 day old new clean Windows 10 install, I don’t think the DLLs are corrupt.

#5

OK, I did a format and a new clean installation of Windows 10 today.
Just drivers installed, no virus scanner, fresh install.
Tested the scenarios and the error still occurs.

This has got to be a problem with Windows 10 and the EX2.

Copying one big +4GB file works as it should but a folder with many files in it gives the error.
Does someone have some information about it?

#6

Same issue. I have attributed it to heat. I now have an external fan blowing on the EX2 and that has helped. The EX2 fan has never come on even though the drive temperatures are hotter than I prefer.

#7

Thank you for your input.
But it doesn’t happen to me when copying 1 very large file.
If it was an overheating issue, I would epect it to happen also then.