Failed W7 install on (2) WD5000HHTZ in Raid 1

This is on an HP Z600 Workstation. Plugged in both WD5000HHTZ 's and they run fine as secondaries, did disk checks, tried to install in Raid 1, Raid 0, and individually with no luck. Goes through install, but when completing installation after reboot , system says that it is unable to install on hardware. 

Thoughts, ideas, random comments?

If you tested both drive separately and you are not able to install the OS on the units, will be better if you run a diagnostic on the drive

You can us the DLG tool to make sure that the drives are working 100%

Also have you tried with a different copy of the OS? Maybe that one is corrupted

I found the drives are able to be installed on separately. I think it is a conflict with the Intel 5520 chipset when running in a Raid format. Unsure if it might be due to the advance formatting or the drives not downgrading to SATA II automatically when in Raid.

Found issue was a bad BIOS update, reinstalled and works without a hitch now…

Good to know, glad that you found the issue and resolved it.

Way to go.