Failed to create volume! error

I have just bought a 4TB Sharespace and I am having a hard time learning how to use it. Before I copy my data over to it I am  trying out the RAID options. I went though the configuration process and the 4 disks were set up as 4 disk RAID 5. I went into the Advanced Manage RAID screen. I tried to change the disks to a SPAN. I get an error “Failed to create volume! System busy, unable to un-mount data volume.” I eventually managed to get the disk configuration changed by rebooting the Sharespace. I then tried changing the SPAN disk setup back to RAID 5. I got the same Failed to create volume error. Even after I rebooted, the disks were still set as SPAN. I finally set the Sharespace back to factory default and after sixteen hours the disks were configured back to RAID 5! I can’t find the error message in the documentation or Knowledge base. I also can’t  change the Volume name.

I am using the latest version of Discovery (1.70) on a Windows 7 and Windows XP PC. I get the error with both PCs. The update button tells me I have the latest version of the firmware 2.1.96 with MIONET

Before I commit my data to the Sharespace I would like to work out if the unit is faulty or there are some tips I need to learn on changing the configuration. I have been using a 2 disk D-Link NAS and it is pretty straight forward to update the configuration. So far my experience with the Sharespace has not been good!

I have been working on this problem for almost three weeks. WD email support told me to pull the Sharespace drives, install the drives on a windows PC and write zeros to the drives using the WD Lifeguard diagnostics software. This took a whole day, one drive gave me an error. I tried again and the diagnostics completed successfully. I installed all four drives back in the Sharespace and the rebuilt process started. After 16 hours the Sharespace was back to the default configuration with all four drives set up as RAID 5. I changed the disk configuration to four disk SPAN. This worked. I tried to change the disk configuration back to RAID 5, but I got an error message that it couldn’t change the configuration because the system was busy. I rebooted the Sharespace and the RAID 5 rebuild started. After 16 hours I got a message that DATAVolume didn’t exist. I reset the Sharespace - same error message. I set the Sharespace back to Factory defaults - same error message!

I took all the disks out and wrote zeros to them again. This time I installed the disks back one by one.

  1. Installed one disk as disk 4 - successfully running as JBOD.
  2. Added second disk as disk 3 - cleaned the disk and extended the JBOD. Successfully running as 2 disk JBOD.
  3. Changed disk configuration successfully to RAID 1 - two mirrored disks.
  4. Added third disk as disk 2. Cleaned the new disk. Disk configuration showed as one two disk RAID 1 mirror and one JBOD.
  5. Changed disk configuration to three disk SPAN successfully.
  6. Changed disk configuration to three disk RAID 5 successfully.
  7. Added fourth disk as disk 1. Disk 1 showed as good.
  8. Changed disk configuration to 4 disk SPAN. Completed successfully.
  9. Changed configuration to two Mirrored RAID 1 arrays. Disk 4 and 3 successfully setup as a RAID 1 mirror. Disk 1 and 2 showed as a degraded RAID 1.

By this time I was convinced that either one disk was bad or one channel of the disk controller was bad. WD email support agreed with me. Before I tried to return the Sharespace to the place I bought it from, I decided to have one last go.

I wrote zeros to all of the disks. Followed the same procedure as above, but this time stared with disk 1.

I noticed that the first time I tried to change the disk configuration I would get a system busy error. If I rebooted the Sharespace and changed the configuration again, it would be successful the second time. Yesterday I finally had all four disks running first as a SPAN, then a STRIPE, then two RAID 1 mirrors and finally a four disk RAID 5 array. Each time I changed the configuration - I got an error message - rebooted and then changed the configuration successfully. I pulled one of the disks and the RAID 5 showed as degraded, but continued running without losing my data. I then put a different replacement drive into the Sharespace - cleaned the new disk and the RAID 5 started to recover, but I could continue to use the Sharespace. Today after 16 hours the RAID 5 is running normally!

The whole point of this excercise was to check out all of the possible configurations BEFORE I copied my data over to it. I never imagined it would take me almost three weeks to achieve this!

I will continue to run my two disk RAID 0 D-Link NAS and keep my important stuff backed-up up to this. After all of the problems I have had with the Sharespace and the problems I have read on this forum - I don’t trust the Sharespace to work reliably.

Maybe if you just plug the Sharespace in and don’t want to change the disk configuration, you won’t have problems. After three weeks I did not get a single reply to my original post. Unlike some people I did get a reply from WD email Support, but I basically had to keep trying, failing and staring again until I got everything working. I don’t think many people would be patient or stubborn enough to go through 3 weeks of this trial and error!

Hope this is useful to somebody:smiley:

Unfortunately, I doubt anyone could have really been able to help you.  It took the determined troubleshooting you did to get to somekind of resolution.  My only question is, did you use the same kind of drive as is in there?  Or something different?  Also, you should be able to RMA the drive that was problematic.

Thanks for the interest! At the end of the whole process all four original disks that came with the Sharespace were running without problems. I pulled one of the drives out to check if the RAID 5 would continue running on three drives and to see if it would rebuild if I put a replacement drive in. The drive I pulled didn’t seem to be faulty. The replacement drive was a WD 1TB Green drive - but an older version.

That’s great to hear.

I have just had the same problem with a new WD Sharespace 2TB attempting to convert it from span to mirror. I upgraded the system to latest version 2.1.92 and then it carried out the conversion.


Having a WD 4TB, one of my HDD failed as displayed on disk manager. I’ve called the customer service officer (CSO) who recited his script so fast that I have to request for a repeat. On doing that, CSO didn’t sounded patience but I manage to take down the instructions. As many has encountered, I was told to remove the failed HDD, run data lifeguard diagnostic and write O the drive and resync for 16 hrs.

Finally, I decided to buy a new HDD but upon slotting the HDD, nothing tells me that rebuilding (RAID 5) is ongoing. Called up Support again only got another guy who ask me to read the WD website. I have to insist that I went through quite extensively on the user manual on how to replace HDD. Basically, nothing was documented stating if the rebuilding is ongoing or there is an error. I have got stable Amber light for my original HDDs and stable green light for my new one. Back to the disk manager, gosh! my original HDDs which was good is now “Failed” and the new one is showing “New”. That doesn’t give me a good feeling and I was advised to wait for 16 hrs. Further reading on the user manual shows that having stable amber means error on my HDDs. Moreover, I have error telling me “Data Volume doesn’t exist”…

I am very, very disaapointed with WD Support and ShareSpace. If only the instructions are good in the website and manual, I wouldn’t have called Phone Support. If only the product GUI is intuitive, I wouldn’t have to freak over the recovery process… yet, I am still waiting for the answer for another 14 hours…

Does anyone knows if the LED lights are just misleading or I have just waiting for trouble with the stable amber lights?

Brown Bear

I had the same problem with an 8tb model.  It had a datavolume and an extended volume.  First I deleted the extended volume.  Then I tried to change the datavolume to RAID 10 (4 disc span) and got that error message.  I went to reboot and rebooted the system.  Then when I returned it allowed me to modify datavolume successfully:
I had the same problem with an 8tb model.  It had a datavolume and an extended volume.  First I deleted the extended volume.  Then I tried to change the datavolume to RAID 10 (4 disc span) and got that error message.  I went to reboot and rebooted the system.  Then when I returned it allowed me to modify datavolume successfully:

AID configuration changed successfully - resyncing/formatting in progress.

P.S. always upgrade the firmware.