Factory reset via SSH, still no write permission


for some reason ( i suspect the WD-mycloud software on a new android device) all write permissions were revoked on a myBook 1TB that has run flawlessly for a long while.

So I followed this link to factory reset without data loss:


which worked to the extent that the names have been reset, all users deleted etc.

I could via dashboard enter an Admin pwd, also create new users, permissions, and shares.

So I could get that back, and see that the data is still on the drive, but…

  1. still no write permission, no rename, nothing. Not for any user, not for Admin, not even in the Public share.

  2. existing shares do not re-link. From the amount of data, I can see that they still are there, but when I create a new share of the exact old name, it can either not be accessed (denied, even for admin), or just is plain empty (without write permission).

Bit afraid how to continue. Would reset via dashboard not only erase all data, but really regain a functional drive?

Hey  JWB000,

Have you tried contacting WD Support about this case.

WD Contact info: