Factory Reset - No boot when Network is plugged in, without network, boots ok

Thanks for the tip Phil! That worked for me. I’d been frigging around with that for months! Champion.

Hey guys, I’ve beign struggling with this for months. I haven’t being able to roll back. I do as told but the firmware works neither shows the option for sync from USB,
Network It was working fine but now it doesn’t.
Any tricks please?

Anton, I also started having this problem a couple weeks ago after resetting to factory defaults. Your method solved it for me. Thanks so very much!

Glad to hear it helps you.

Mine still working after those issue.
Still using it as small multimedia nas with video/audio collection)

To rollback:
Download this: http://download.wdc.com/wdtv/Rollback_wdtvlivehub_2_08_13.zip
Unarchive and put files onto root of flash drive.
After that open with notepad or editor you like file wdtvlivehub.ver
And change VERSION=‘3.08.13’ to VERSION=‘4.08.13’
Save, safely remove usb drive and try once again with livehub.

1 Like

How did you do this step? When I open my .zip file, I don’t see an actual ver. number, just “wdtvlivehub.ver” along with 2 other files - “wdtvlivehub.bin” & “wdtvlivehub.fff” (without the quotes). I do not see anything to change. And upon double-cklicking “wdtvlivehub.ver” all I get a a view-window that pops up taht will not let me edit anything. Not only that but a separate issue I’m having is I get a message that states “The firmware you are attempting to install is not compatible with this hardware” when I attempt to rollback to 2.02.16

Thanks Anton, I try this before with other versions, I’ll try today with this one, crossing fingers will have better luck. the other problem too is I never get to see the FIRMWARE UPDATE tab on the home menu or anywhere.
I’ll let you know how this goes.
Cheers

image
Yous should see this 4 files, Right Click on the .ver and with CRTL + Richt click try Open with to open the filw with Notepad

Make sure “Detect New Firmware” is activated in the Settings. (Setup > System)

Done! network is working again!!! thanks. Now firmware is 2.08, Which version should I upgrade it to?

You are a legend!
Done! network is working again!!! thanks.
Now firmware is 2.08, Which version should I upgrade it to?
What do you recommend?

If the network is working again and media playback works i personally wouldn’t bother upgrading.

If you do run into a problem, check the release notes of each firmware released and if there is anything in the release notes that addresses the problem … then flash that firmware. If there is nothing in the release notes … then not much you can do since these devices no longer receive support or firmware releases for the last 6 Years.

Thank you so much, you saved my day. Your solution and explaning how to update the firmware are quite detailed. Brilliant !

1 Like

Glad to hear it was useful.
As JoeySmyth says, if everything works, just use it as is.

In my case i want device connects to wifi with asus usb-n13.
So after reset i just flash it to the latest available and touch nothing more.
It just works.

Please aware, it is instruction for rollback firmware.
If you want to upgrade to the latest, you can do it as usual, via internet of flash drive…

Hi Anton,

Thx for posting. It worked for me too. I just had to follow steps exactly! The files cant be in a folder for the rollback otherwise the WDLivetvhub wont see the upgrade for the rollback. And you you have to factory reset after the 1st rollback - just like you said.

Thanks again, very kind of you to share!!

Wow…this is the ONLY solution that actually worked! And in fact, you don’t event need to bother to update to firmware 3.12.13, as it is somewhere between one of the firmware updates that this problem was created. Those people at WD really need to get it together.

I have been working on this off and on for over two years and at this point this is what I was able to find. Assuming you figured out how to do the rollbacks in versions.
From Ver. 2.08.13 to 3.0.28 Only work with original WD drive.
Ver 3.00.28 to 3.11.10 All have the network issues.

Something changed in the version after 2.08.13 that created network errors. However Antons method to not reset does not resolve these issues and staying at 2.08.13 creates another issue whereas the HDD only support the original WD drive. Maybe a WD branded drive will work however I have not attempted this.

I have tried the method described in this thread. My problem is that after a factory reset (underside pin) the WD Live TV Hub would boot only if the ethernet cable was NOT connected. My firmware was 3.08.14.
Following the methods posted in this thread I downloaded firmware 2.08.13, renamed it to 4.08.13 and successfully rolled back the firmware,
However the WD Live TV Hub still behaves the same way, Boots normally if no ethernet cable connected, will not boot if connected with “loading” status then restarting over again.
If I start the hu b without ethernet, and plug it in while it is on, it crashes and goes into a “loading” loop again.
Did I miss something to after rolling back the firmware?

Please ignore my previous post. I found what I had failed to do; another reset.
Very late but thank you to Anton and everyone who posted in this thread.
I am back on my network again.