External WD HD Driver issue in Windows 7


#1

I have a 320 Gig WD My Passport Essentials HD (Model: WDBAAA3200ABK-00).  The drive works perfectly on my Windows Vista HP laptop, however on my new Dell Inspiron 570 the drive will not load.  I have tried all of the USB ports (front and back) as well as purchased a Dynex powered USB hub…thinking that the USB did not have enough power for the drive.    When the drive is plugged into any of the ports, it is running with a white light flashing.  I have noticed that it is detected in the Control Panel under Devices and Printers as “My Passport 070A”.    The device status is "No drivers are installed for this device. "  There is no option to update the drivers either.

Thanks in advance for considering to suggest an answer to this issue.  Cheers, J


#2

I have the same issue, except mine has to do with when I uploaded to Windows 7 Ultimate. I don’t see why it would work with one operating systems and not another…

If you get an answer to this from anyone let me know because this is really starting to get on my nerves I am highly unsatisfied at this point.


#3

@angelsweet4eva-

I’m just trying to be patient.  I hope someone is willing to help.  I also posted on Microsoft’s Window 7 board.  MS asked if WD offered any suggestions. 

I’ve noticed on other posts that some have advised the use of a booster USB cable.  I think this approach is negated since I used a powered USB hub.  Specs state that all ports run at 500mA on the hub.  Anyway, even my existing ports on the desktop have been able to “spin” the hard drive… 

Any suggestions out there, Western Digital?


#4

Ok, I guess I will try some self help here   :smiley:

I noticed that my drive is Window 7 compatible per the WD Link :    http://www.wdc.com/en/products/products.asp?driveid=698   So, have others been successful in running this drive on Windows 7? 

Is it fair to assume using a powered USB HUB would be the same as the miracle working booster cables?  (It’s hard for me to justify spending more $ on this drive )

Is this forum monitored by WD personal?  I know my issue isn’t an emergency…but a little customer service / attention would be nice…This is my 3rd hard drive I’ve bought from WD.

Thanks again for any responses / ideas. 


#5

WD doesn’t monitor the forums.  If you are waiting on Tech Support to respond, you will be waiting for a long time.  You may need to contact them about this. You can do so either by phone or email. 

However, just for you to know, a powered USB hub doesn’t necessarily mean you are getting enough power supplied to the drive.  Try directly connecting the drive on several computers with the 18 inch cable. If it works on some, but not on others, then you need the power booster cable for the computers it has problems with.

To Contact WD for Technical Support
http://support.wdc.com/contact/index.asp?lang=en


#6

Thanks for the response and suggestion.  I’ll contact WD Tech Support.  Extremely frustrating that power booster cables may be needed.  They should be supplied at no charge.


#7

Hello… I have read your posts and was wondering if you found another solution for your device. I have the very same problem and do not want to spend more on this storage device.

Please email me at minilorenz@yahoo.com

Thanks


#8

Contact Western Digital Tech Support.  I spent about 45 minutes trouble shooting.  They can help, but you’ll need to invest a little time.  I will hopefully be receiving my “Power Booster” Cable in the mail this week.  If it works, I will add another post here.


#9

Just thought I would add an update…

WD sent the "power booster " cables…it still did not work with my Window 7 system.  They then issued an RMA and are in the processes of sending me a new drive.    I’ll post something if it works…  or not.  :smiley:


#10

I have an HP Elitebook 6930p which was loaded with Win 7 in Nov 2009. My WD Elements external hard drive worked perfect from the laptop USB port untill 22/06/2010 when the Initio Default Controller was installed without my permission. Since then I cannot get my HDD tobe recognised and made accessible.

When I couple it up to my old XP tower thesame thing happens, THIS DID NOT HAPPEN BEFORE!

Have emailed WD regarding the problem but had no response from them.

Has anyone got any suggestions.

Note: When I disconnect the power souce (Power pack for HDD) and then connect a jury rigged 12v/5v supply from my tower PSU all works fine.


#11

hey, just found this thread as i was trouble-shooting the problem…

for me, the issue is that my model passport 070A is setup for MACs and NOT PCs.  I tried to run it on two different machines with windows 7 on working USB ports and it will pull up but show as drivers not installed. 

Fix?  attach it to a mac…