External USB drive bay no longer recognized

I just purchased WDTV Live SMP and connected via USB a Hormettek Enterprise 4x drive bay containing 2 Seagate 2TB drives, JBOD formatted with MAC OSX Lion Disc Utility…downloaded all updates for WDTV too.

I placed a few mkv movie files on the drive to test and worked fine on WDTV, even retrieved metadata info, everything worked.

Then connected drive bay to my iMac to transfer the rest of my files, ejected, and reconnected to WDTV.

Drive was not recognized right away, but after a few power reboots, it was recognized and successfully updated all the metadata and thumbs for all files.

Powered everything down, came back a few hours later, turned everything on and drive is not recognized again…even after many reboot attempts…connected a different USB thumb drive to test ports and they work fine.

Any help would be GREATLY appreciated! - sorry for the verbose explanation, just trying not to leave anything out - thnx.

BTW - I’ve searched the forums already for similar issues…closest wthe another Mac user who mistakenly formatted their external drive as case sensitive, which I did not do.

IIRC, WDTV doesn’t support RAID / JBOD via USB…

1 Like

Thank you!  I’ll do some searching to see if I can confirm that - I did quite a bit of research before purchasing all the hardware for this project and I’m pretty sure I’d seen somewhere that certain RAID formats were problematic but that JBOD was ok - however, who knows if the source was reliable ;). 

Another possibility is the disk format.  Mac OS Extended (= HFS+) is OK, but I understand it can’t be set to journaled.  You can turn journaling off in Disk Utility if you hold option down while going to the appropriate menu item.

However, I have had some random problems with my simple USB drive formatted this way.  I was fine as long as I did not turn on the Media Library thing.  Once or twice since then, the WD has damaged the file structure on the drive.  I had to hook it back to the computer and repair it with Disk Utility before it was recognized again.


1 Like

Well tonight it worked after I switched to the front USB port instead of the back…which is strange because: A) the first time I connected the bay it was in the back port and it worked and B)  there’s nothing wrong with the port, I inserted a thumb drive in there and it read fine.  Now I’m really confused.  I guess I’ll wait and see what happens tomorrow when I turn it all on again.

Does anyone know the proper order both the SMP and drive bay should be powered up and down?  Do I need to eject the bay everytime I power down if I want to always use the Media Library function, or is it better not to eject it and just turn the power off on both devices?