External HDD not recognized after WD powered off, then on

Hi all,

I’ve recently bought a fantasic WD Live & upgraded to the current firmware (within the last 4 days). I have a new Samsung G3 1TB external HDD with the media I am playing through the WD Tv Live - media works fine, no corrupt data, virus-scanned with up to date 2010 version of Norton 360.

My problem:

Annoyingly, if the WD unit is turned on, the external HDD does not power up and therefore is not detected by the WD Tv Live.

If the HDD is plugged into the other USB port on the WD Tv Live, it automatically is detected & powers up - no problems.

If the unit is turned off, then on again at a later stage, same thing happens.

It doesn’t work if the HDD is simply unplugged and re-plugged into the same USB port. The other port HAS to be used to make it recognize the HDD.

There is nothing else plugged into the WD Tv Live unit.

-eg No ethernet, no other USB device

The unit is attached to the TV via the supplied AV cables.

Any ideas? Its really frustrating having to swap where the HDD is plugged in every time I start up the unit.

Thank you

i read it in their tech support section that if you connect the harddrive to a computer and disconnect without using the “safely remove harddrive” feature, there is a little data left on the drive which tells the system that the harddrive was not disconnected properly and this prevents the auto loading of the HD.

to fix this, connect it to your pc, use the safely remove feature and then reconnect it to the media player, the media player should start re-indexing all your file.

note: there is a little icon at the bottom of your windows screen (look for the icons near the digital clock at the bottom right) that allows you to remove harddrive safely - it only shows up if you connect the external harddrive to the PC.

hope that helps.

Hi there,

Thank you for the reply.

Tried connecting to the home PC, safely removed hardward (and double checked i removed the correct item)

Connected back up to the WD Tv Live, same thing happens.

Tried “ejecting” the media via the WD Tv Live menu, connected HDD to pc & re-safely removed the hardware.

Connected again to WD Tv Live, bah, still the same

  • however, just unplugging & repluging in the external HDD into the same UBS slot now works… so that is a bit of improvement.

Just tried again & everything seems to work!

Thank you for the help :smiley: