External HDD no longer recognized

We’ll I’ll try to put as much detail as I can. This actually happened to me before and I couldn’t find help when I was searching for a fix but I’ll try again. I’ve had my WD Passport for about 3 years now I believe, it’s a portable 500GB. It was actually working fine this morning. I’ve got some important stuff on there but I’m a musician and I had some music stuff on there I was working on. I went to work on it hours ago and it wasn’t showing up on my Windows 7 laptop. Tried plugging it into my Win7 PC, my brother’s Android tablet, and his Win7 laptop and still nothing. I know all of those were recognizing it, though. Went to devices and printers on my PCs and it shows up as “External HDD”. It doesn’t show up in My Computer and in Disk Management it shows “Disk 1 Unknown Not Initialized” (won’t let me initialize, either) and shows 0MB in it’s properties. I use this drive a lot for many different things so I really want to try and recover the data off there. Like I said, I’ve actually had this issue before. I had a 16GB Lexar USB flash drive I used for my Xbox 360. I had it maybe a couple of months when it stopped working right in the middle of a game (signed me out and told me it couldn’t save). Same situation, but I believe at that time it showed up in My Computer but still displayed no media with “0kb” and I was unable to find a fix. Even gave it to a friend who works someplace where they do data recovery and he couldn’t fix it, either. So I had to throw away a brand new flash drive (it was cheap and on sale, plus I only had a few Xbox stuff on there, so I didn’t care that much). I REALLY don’t want to have to toss my 500GB drive that I use a lot for the same reason. I have a 3TB WD for my home PC but it’s being used for backups (not for my portable external, ironically…) and recorded TV for media center and it’s not something I bring with me so I don’t want to have to go out and buy a new portable drive either as I’ve noticed the prices are still slowly going down back to what they were before the flood in Taiwan and they’re still a little pricey. Any suggestions?

If the passport is still recognized on the disk management window, you can try to use a data recovery program. If it doesn’t allow to you initialize, you probably need to replace it. 

It shows up as Disk 1 in Disk Management but will not let me initialize. Are there any data recovery programs you suggest?


I’ve tried a couple programs that didn’t help me, but some recognize the drive and others don’t. With WD’s Data LifeGuard, I get these results.

Model Number: WD
Unit Serial Number:  
Firmware Number: 1.75
Capacity: 0.00 GB
SMART Status: Not Available
Test Result: FAIL
Test Error Code: 08-Error was detected while repairing bad sectors.
Test Time: 21:09:17, June 07, 2012

After doing a test it tells me “Test found bad sectors that may be repairable”. When I hit repair it gives me that error message. I’m hesitant on choosing the “write zeros” option to completely erase it because I don’t want to lose anything I have on it, but it is the only program I’ve encountered so far that is giving an erase option, others don’t even give me a format option.