External HD to Internal HD after firmware failure

First off, to all, thank you in advance for your time in reviewing this.  I am reaching out to the WD community following a series of problems I have had with a WD 2 TB MyBook Elite external harddrive.  About three months ago I went to do a firmware update and the update failed, rendering the drive inaccessible. The firmware problem appears well chronicled in other threads here so I’ll rack on this no longer.  I found that some WD owners with similar issues were removing the drive from the external casing and installing it on their systems as an internal drive and had success in getting to the data that way and transferring it onto a replacement drive.  So I have attempted to do this as well.

For $30 the Best Buy Geek Squad removed the HD from the casing without damaging it, thus preserving the warranty on the drive itself.  So, kudos to them.  The computer I have attempted this on is an older computer, 2 Ghz, 512MB running XP Pro.  Since the 2 TB drive is a SATA drive and my computer has IDE connectors, I bought a 2TB capable SATA to IDE converter, attached it to the drive, and attempted to install this 2 TB drive as an internal drive as a slave drive.  The drive was recognized on the computer, both in the BIOS and by the Device Manager.  However, the computer did not assign a drive letter to it and I later discovered this was because the disk had not been initialized on the PC. Since initializing was not the same as formatting and Windows did not warn of a data loss, I went ahead and initialized the drive.  So, now I have an initialized drive but still no drive letter and more questions than answers at this point on proceeding forward.

Some resources are indicating that once you initialize the disk you cannot retrieve the data, other are saying you can, so I am uncertain what to believe at this point. On this disk is about 1.8TB of DVDs I had backed up, primarily VOB and IFO files, etc.  I would be interested to hear back from people who have had this issue before and if they were successful in being able to recover the information from the disk.  If so, what steps did you take and/or what programs did you utilize for recovery?  If I had a spare $1000 I’d throw the harddrive to a recovery specialist to get the data back and transferred to a replacement drive.  However, if I also had a spare $1000 I wouldn’t be running the same XP Pro, 2 Ghz system I’ve been using since 2003.

I have looked at one product called Recover My Files and wonder if anyone has had any success with this.  Thank you again for taking the time to read and respond.



Hi there and welcome.

 On this disk is about 1.8TB of DVDs I had backed up,

If the data is only on this drive then by definition it is NOT a backup, since a backup is a secondary copy just in case the first one fails. If the drive truly had a backup then no data would be at risk, just so you know.

On the other hand, initializing the drive does not give any drive a drive letter… Formatting does. The drive will not be seen on Windows explorer until it is given a file system that Windows understands after the new initialization as an internal drive.

Good news are that if you are were able to initialize the drive then it means it is not encrypted.

I have not used Recover My Files but I can suggest you to try TestDisk, which is free and has given good results here, if it doesn’t work for you then yes, try the software you have in mind and many different ones. Since the drive itself is working then trying different softwares is the way to go.

Best of luck.

On the other hand, initializing the drive does not give any drive a drive letter… Formatting does. The drive will not be seen on Windows explorer until it is given a file system that Windows understands after the new initialization as an internal drive.

Thanks greatly for the response.  What you said makes sense, but now raises for me another question.   How do I get to the point where I can get my computer to read the data on the drive so I can make the transfer?  If I’m understanding what you’re saying, formatting the drive tells Windows what file system the HD has and also assigns it a letter at that point.  But also as I understand formatting the drive also erases the information that was previously on it.  So, I’m uncertain how to proceed.  Thanks BTW for the recommendation on TestDisk.

The computer alone won’t read the data on the drive while it still needs to be formatted.

That’s when TestDisk, File Scavenger, Recover My Files and many other data recovery softwares come into play: They can.

If you initialized the drive as a Master Boot Record (MBR) patition table, then TestDisk will try to repair it first to grant you direct access to the files without formatting, if the file system cannot be repaired then most data recovery softwares tend to extract the files directly from the lower levels (Sectors and clusters) of the drive.

Cool.  Thanks for all your help!!

If the USB-SATA bridge board in your WD enclosure has an Initio INIC-1607E chip, then your data are hardware encrypted, whether or not you have set a password. This is why the PC failed to recognise the partitions. Now that you have initialised your drive, you have wiped the encrypted partition information, but hopefully your encrypted data are still intact.

Your easiest course of action is to obtain another MyBook Elite and swap the drives. Then run TestDisk or “Partition Find and Mount”. Hopefully your data will be accessible. If not, then one commercial tool that has worked for others is “Active File Recovery for Windows”.

That said, a failed firmware update usually causes the Initio chip to identify itself as an “Initio default controller”. In this mode it has prepared itself to receive a firmware download. If this is the case, then you should be able to update the firmware simply by repeating the procedure, ensuring that no other application is attempting to access the device at the same time. The firmware is written to an 8-pin serial flash memory chip on the bridge board, not to the drive itself.

You can see the Initio device using Microsft’s UVCView utility:


Partition Find and Mount:

Active File Recovery for Windows


Thank you kiindly for taking the time to share your knowledge on this.  Until you mentioned this, I didn’t grasp a full understanding of why when I tried to plug the drive back into the USB port it wanted to install an Initio controller board.  It didn’t really make sense.  I have a gentleman in my local area looking to see if he can help in this situation and have pointed him to this thread.  I actually do have two other 2 TB Elites that if need be I can possibly pull here for this, but I am going to let my local guy dictate whether he wants to go this route.

Thanks again.


Here is an enlightening discussion:

The OP in that thread has done some excellent detective work on a HP SimpleDrive which appears to be an OEM version of a WD SmartWare product. If you are unable to apply the firmware update, then see the last page for a simple hardware hack.