External Hard drive not working

I’ve had a 2TB My Book Essentials for about 2 months now, I use it to store all my extra stuff and now all of a sudden its not being read by my computer I’ve gone under device management and it shows up there and if it does show up in My computer it’ll just show as a Local Disk and I can’t get into it or it’ll say I need to format my drive before I can use it Could someone tell me whats going on with my external Hard drive…this is the 2nd external hard drive I’ve bought 

Hi there

Your drive may have data corruption or bad sectors I’d suggest to you to use TESTDISK to run a test on the drive.-

I have 2 GB hard drive, it was ok with my laptop vista and desktop pc windows xp but from last month it is not working. I’ve stored my data on it and now when i attach to computers, its light shows on but device is not shown on screen. Is there any solution to retreive it?

Did you try the program mentioned above TestDisk? Moving drives between different OSs can cause problems.


I have the same problem with a WD My Book Home edition.

I have tried following the instructions for Test Disk but can’t get past the Please Wait screen in Test Disk after I hit the enter key (on No Log).

I am running Windows 7 - 64 bit.
I have an external WD 1 TB hard drive connected with USB that is partitioned into drive G and drive H.

H is where my important data is and it is suddently “not accessible” and it wants me to format it to use it.  I click NO to that then the box pops up DATA ERROR (CYCLIC REDUNDANCY CHECK).

G still works fine so I know it is not the actual hard drive or cable causing the problem.

Both were formatted NTFS and given a name of WD 1 TB first (G) and WD 1 TB second (H). 

G still has it’s given name and is still NTFS.  H is now just  LOCAL disk that is listed as RAW.

I have tried restarting the computer but that does not change anything.

I have tried a cold boot and that brought the drive back so I started a backup and went to bed.  Got up in the morning and the backup had stalled out, early on, as drive H went back to being a LOCAL drive that is RAW.

I downloaded both versions of Test Disk and tried to run them as administrator. 

I tried the 32 bit first as I assumed I had WoW64 from what I had read. 

 When that didn’t work, (stalled out with please wait after choosing No Log and hitting the enter key) I downloaded and ran the 64 bit version but the same thing happens… I choose No Log, hit the enter key, then am greeted with Please Wait… but nothing ever populates after that and I’ve waited up to a half an hour.

What do I do next?

thank you in advance for your assistance,


It sound like some of the partition data got corrupt. You can try free Easuse Partition Manager  http://www.partition-tool.com/personal.htm .  I have read that running the procedure to convert from FAT32 to NTFS will sometimes fix the problem of Raw partition even though it was formatted NTFS to start with  http://windows7forums.com/windows-7-hardware/52429-hard-drive-unrecognizable-file-system.html . In this link  http://www.ehow.com/info_8555094_command-fat32-partition-ntfs-partition.html  that part is toward the end in Syntax. One other option to try recovering data is create a Linux Live CD http://www.knopper.net/knoppix/index-en.html It doesn’t actually install on your system but sometimes allows access to data.


As I look around the net it seems that the failing WD drives is a constant. Will be leading my customers away from these drives. Sorry folks loyalty only goes so far.