External drive not recognized by computer

Running Windows XP - passport shows up under device management as healthy and active; I have assigned it to Drive “F” but doesn’t show up under my computer for me to move files to - I can’t call into the help desk due to my hours of work so I am here to see if anyone can give suggestions on how I can get it to show up as a drive.  I am trying to move all of my files to another computer.  Thanks !


What is the status of your disk drive within the Microsoft Windows Disk Management? If the device is listed as “Healthy” but does not list a File System such as NTFS then it may need to be re-formatted (Erased) for usage.

It does show healthy and is listed as NTFS and now what’s really weird is that under Drive “E” on my computer, it’s showing WD Unlocker but I still can’t access the passport as a drive - either way, it won’t let me format under disk management.  I get an error message regarding the partition is not enabled and to hit restart.  Although I have tried this, it still doesn’t let me do anything.  It’s getting very frustrating - Do you have any suggestions?  Thanks.


If the Unlocker is being displayed then the encryption system is likely active. The device will not mount until the current password is used. This can be doubled-check by opening the Unlocker and running the application.

Sorry, haven’t been on in awhile - sent my drive back per WD’s suggestion - received the new one yesterday and still have same problem.  I brought the drive with me to work and plugged it into my computer and it recognized it immediately.  Working with Windows 8 here at the office and on XP at home - I am trying to upgrade to another computer hence buying the external hard drive to move my files over so I can copy them onto new computer.  I’m now thinking it has to be my USB drivers - ARRRRGGGHHHHHH