External cloud access works no more

Hi to all!

I bought a WD MyCloud EX2 a couple of months ago and it’s been working pretty well since.

I also set up the cloud service to access the contents of my disk from outside, using the appropriate applications for both Android and Windows devices. These applications worked as a charm.

However, since a few days ago, the external cloud access stopped working. Every time I try to connect to my device using the aforementioned applications I get an (translated from spanish) message saying “unable to connect to this device”.

The problem began the last time I restarted the disk (I had switch off electricity at home to make some domestic repairs and turned off properly the disk to avoid any damage).

The original cloud set up used an automatic connection method (that worked). I tried to use the manual and XP ways to set up this connection with no success at all (even restarting the device after every change). To no avail.

Later on I realized that an automatic firmware update was performed on September 3rd, which installed version 1.04.05. This, apparently, didn’t jeopardized my sistem… but I wonder if after the restart I made a few days ago, this firnware update didn’t apply, being therefore the cause of the problems I’m experiencing now…

Just to tell everything: there’s been no changes in my network (neither hardware nor software) during quite a long time, so I guess (I suspect) that this firmware update is the one to blame for this problem…

Any ideas? Any help? Whatever you may suggest will be welcome.



Hello, see if the link below helps. 


1 Like


excuse me for the delay in my answer. I’ve gone through a rather hectic week and had no time to check your suggestion.

I have to say that now everything works well again.

I had to use the manual connection, forwarding ports 80 and 443 in the router to the fixed IP address associated to the cloud drive.

So thank you very much!

HOWEVER, this manual connection method was not necessary at all BEFORE the update to the latest firmware was applied. An auto connection method worked well. So, I think, it is not too risky to say that this update was the cause of the problem.

Thanks again,



well, the problem seemed solved, but after a few days, the cloud service has stopped working again.

The only solution found up to now is to turn the cloud service off (using the control panel) and turn it on again. I guess that in a few days it will stop working again.

This is rather a nuisance, but, at least, I can have the cloud on applying this “solution”.

Any other ideas?


Pep, is this solved or not?  You have marked it as solved, if it is not solved go to the message you marked as the solution and click on the options drop down in the upper right to remove it as the solution.  Then you will probably get more input.

I would ask if you have WEBDAV enabled?  If so disable WEBDAV and lets see how long cloud access works.   By the way, after shutting off WEBDAV I’d reboot the drive to be sure all services are started appropriately.  If this works please mark THIS as the solution.

Thanks for your suggestion.

I would say that the problem is “solved as much as to make possible to use the cloud”, but not completely solved.

I don’t know whether webdab access is enabled or not. I’ll check this when I get back home and, if necessary, proceed as you say.

Now, the time the cloud keeps alive is about three days. Just a few minutes ago tried to access it from work and noticed it had stopped working again (that’s why I revisited the forum to see if anyone had suggested a way to correct this problem).

I’ll come back tomorrow to the forum to report what I’ve found this evening.

Thank you,



I’ve had the time to check whether webdav was on or off.

It was already off. So the conclusion is: the problem is present when webdav is off… In fact, all services (starting at “Jumbo frames” and down) are set to off, since I don’t need neither ftp, nor ssh nor…

Should I start any of these services?

Thank you!

(I beg for a new firmware release…)



Lets get the details of your current setup.  Please let us know what your network configuration looks like, and how you have configured the EX2 for both the protecols you are using as well as the ports you are using.


Router type and how connected to the WAN?

Connection to the Internet, either cable modem or DSL / vdsl / adsl through a gateway?

How is the EX2 physically connected to the router?

Are you using a static or dynamic address for the EX2? (Should be static or reserved via DHCP)

Are you using the standard cloud setup or are you manually configuring it? (If manually need details.)

Are you forwarding any ports from the EX2 or are you forwarding them from the router?  (Dont do both)

What network protecols have you enabled?  In the case of SMB what version?

Hopefully that will get us started.


I hope that I can answer at least some of your questions. I’m neither a noob nor a real expert, but something in between, so… let’s go (I’m at work now, so can’t answer all questions):

  • Router type: must check (it’s the one sent by my ADSL provider),
  • I’m using ADSL. If there’s any gateway, I assume it’s located at my provider’s headquarters, not at home…
  • The connection between the EX2 and the router: wired to one of the free Ethernet ports in the router.
  • The EX2 is using a static IP, set by me (
  • To connect to the cloud I use port forwarding. The auto option stopped working when the last firmware version arrived.
  • The ports I forward are the suggested ones in the control panel: 80 & 443. Firstly, I forwarded these only in the router, but it didn’t work. So then I ALSO FORWARDED both ports in the EX2, which made the cloud work (although it stops working after a few days). I see in your answer that you say “Don’t do both”, so this is wrong, isn’t it? As I told you, when I only forwared these in the router (80 to 80, 443 to 443, both TCP & UDP) the cloud didn’t worked from outside my local network…
  • Protocols… well, the only thing I’ve done about protocols is to disable most (if not all) of them in the EX2 control panel as I already commented in a previous post. I’ve done no protocol configuration in my local network (I wouldn’t know how to do this). Concerning the version of Samba… well, I don’t know. I guess that the firmware 1.04.05 in the EX2 includes its own, but don’t know which one)

Excuse if one or more explanations are inaccurate or answer the wrong question. As I said, I’m not a real expert…



Just one comment:

the EX2 works PERFECTLY within my local network. No problems at all here. It’s only when I connect from the WAN that I have problems…


You should NOT forward the ports in both the EX2 and the router.  Its also possible that your ISP is blocking port 80, a lot of them do.  So here is what I would do;

1.- I would setup the EX2 to use DHCP for its IP address.

2.- I would then go to my router and RESERVE the IP address for my EX2 based on its MACID.  (This way the DHCP server is fully aware of the IP address of the EX2.  Even though if the router is working properly this shouldnt matter, I have seen it make a difference.)  You should reboot the EX2 after doing this and confirm its IP address matches the reservation set in the router…

3.- I would go into the EX2 and setup the Cloud access manually to use ports 8081 and 8443.

4.- I would then go into the EX2 network config to manually add port forwards for 8081 and 8443 , naming them Cloud and Cloud1.

5.- I would then go into my router and remove any manual port forwards I have assigned.

6.- I would also go into the router and confirm UPNP is enabled , and that the newly assigned ports show up.

7.- Confirm that when you enable cloud access it says “Connected”.  When you manually configure the ports it will probably say relay connection established.  This is OK.  We just want to confirm the EX2 has connected to the WD servers.

8.-  IF the newly assigned ports show up in the UPNP routing table and the EX2 confirms it is connected, I would then attempt to access the EX2 from outside my network.  (Try using your cell phones hotspot feature if you have it.) 

9.- IF I could not confirm UPNP functionality then I would manually configure the port forwards in my router and remove the port forwards I added in the EX2 network config.  Then re-confirm that the cloud shows “Connected” and test again from outside.

If this works then my last test would be to first reboot the router, then after the router is back online reboot the EX2, then test outside access again.

Let me know what you find.


Wow, thank you!

These are very precise instructions! I’ll go through them step by step,… I don’t know when, since my work week is pretty hectic. Probably, I’ll have to wait until next weekend.

I’ll come back to you and the forum after all these tests have been performed and let you know if it worked!

Thanks again,



last Saturday I had, finally, the time to put your instructions into practice. When I finished step 8 everything worked correctly (I didn’t need to go through step 9). After the final suggested reboot, thinks kept working well.

Now the EX2 has been working for more than 48 hours and the cloud service may be accessed from outside my LAN without problems. Last time, before I changed its configuration according your instructions, the service broke after only one day, so it looks like the problem is solved.

However, since I remember seeing it working for 3-4 days, I’ll wait until, let’s say, the next weekend to see if the problem does not show up again. If after this time everything is still OK, I’ll close the issue and mark your post with the 9-step instructions as the solution, so other people experiencing similar problems my benefit from your contribution.

Whatever the result is, THANK YOU VERY MUCH!!!

By the way: I haven’t found a so detailed cloud-connection tutorial as yours anywhere. Congratulations for your explanations!

In fact, when other people say “redirect ports” they don’t explain the double forwarding problem you mentioned; they neither tell about the convenience of using DHCP plus IP reservation… and so on. What I mean is that many bits of knowledge are assumed… which is not true when final users, as me, are not seasoned network maintainers. In other words, the EX2 does not seem to be a “final user product” in the senses that you may just plug it to your router and hoop-la! everything will work. Step-by-step instructions are therefor so much needed.

Wouldn’t it be a good idea to “sticky-post” these instructions at the beginning of forum? Can you do it? I would vote “YES”. Such a post would have helped me from the very beginning, saving, much probably, lots of time and worrying about. So, again, thank you very much.




The only problem with using UPNP to configure your ports that I have seen is most routers clear the UPNP configuration on every router reboot.  Therefore, if you reboot the router for any reason and dont reboot the EX2 afterwards you will lose access to the drive.  To avoid this scenario you can either make sure to always reboot the EX2 after a router reboot, or you can add the 8081 and 8443 manually in your router port forward table and remove them from the EX2 port forward config as in Step 9. 

As for making a sticky, I have no admin privledges here at all, that would have to come from someone else.  Thanks for the response.

Dont forget to give up some Kudos!  LOL



1 Like

I still haven’t gotten the cloud access to work on my EX2, seven months after I got it. It was never my top priority anyway (wanted more an sftp sever) but would have liked to get the cloud access going if I could but on the couple occasions I tried, I had issues with it. Coupled with the fact that I’m very hesitant in using UPnP features of my router for several past security vulnerabilities, I never seriously tried it…but sounds like Vertech1’s steps has it down to a pat…so I might give it another go. Going to be busy next couple days but will post back here how I make out with these steps.

My only question to Vertech1…so can the cloud access work if I setup port forward only on the router like you mentioned and don’t do any port forward stuff on my EX2? And is it still then using UPnP (I’m thinking it’s not) if I setup this port forward on the router? I must admit I never quite got how and why port forwarding on the EX2 even worked…I understand the port forwarding bit on the router obviously…been doing that for 12 or so years…but don’t get this port forwarding bit on the EX2…confuses me :slight_smile:

My only question to Vertech1…so can the cloud access work if I setup port forward only on the router like you mentioned and don’t do any port forward stuff on my EX2? And is it still then using UPnP (I’m thinking it’s not) if I setup this port forward on the router? I must admit I never quite got how and why port forwarding on the EX2 even worked…I understand the port forwarding bit on the router obviously…been doing that for 12 or so years…but don’t get this port forwarding bit on the EX2…confuses me :slight_smile:


To answer your question, yes it will work.  Just follow the guide with the exception of the network config on the EX2.  Do not configure any port forwards on the EX2, only forward the cloud access ports on the router.  Rememebr you have to tell the EX2 what ports to monitor for cloud access.  Then you have to go to your router and tell it to forward the same ports to your EX2. 

If you setup the EX2 to use UPNP to forward the ports AND your router is setup to forward the ports it COULD cause a conflict during data operations since the router will be trying to forward the ports via the UPNP function as well as the manually configured port forward function.   

You also have to be certain that the ports you expect to use are not being filtered by your ISP.  (80 & 8080 is known to be filtered by many ISPs, I know Uverse has several that they are filtering from personal experience.)


The port forward section under network config of the EX2 is there only to help those that do not know how to forward ports on their router.  Of course if their current router doesnt support UPNP or has had UPNP disabled that whole port forward section simply wont work.  This should probably be better documented by WD.

1 Like

Gotcha. Thanks.Vertech1 - will report back in a few days when I get the chance to do this.

And to the OP - you can kudo Vertech1 by clicking on the star below his username, to the left of his post, to say thanks.


this morning my cloud access stopped working again… :frowning:

Since you comment that a router reboot might remove the UPNP configuration, I’ll check with my son whether he’s reset it because of any kind of internet problems… which happens every now and then.

I’ll come back and report.

Nonetheless, I’ll give you the kudos, of course!!!



my son tells me not that he reset the router by himself but that the connection to the ISP failed 2-3 times, so an automatic reconnection took place.

Could this also be a reason for the UPNP ports used by the EX2 be removed from the router port table?

Looks like I will have to apply the solution you suggested to another user, that is, remove the network part in the EX2 configuration to avoid the automatic use of UPNP ports and add the forwarding rules manually in the router…

However, I still have to check if the UPNP ports were removed by the reconnection problems (I’m not at home, can’t check this now) to confirm that this is the problem.

Thanks once more!


It’s hard to say without being there, but its not unheard of that with a loss of connection the router may have automatically rebooted or flushed the UPNP port forwards.  As discussed, try setting up the port forwards in the router manually and remove them from the EX2 network config. 

I just went back and looked at the equipment description you provided, it appears you are using a modem/router combined unit provided by your ISP.  Most of these will do a soft reboot upon a connection loss which will flush the UPNP tables at that time.  Set it up manually and see how it goes.

** You could also talk your son through getting into the UI of the EX2 and rebooting it.  That should re-establish the UPNP port forwards on the router until you can get home and set it up manually.  I dont advocate power failing the EX2 to force the reboot as that could cause file corruption.