Ext2 ssh turn off services


#1

I got 6 of those ex2 ultra nas and in all fairness they are all pretty bad lately.

All seems to freeze between 1 - 3 weeks and no more dashboard access either. I saw quite bit of posts about going in via ssh and deactivating certain scan services. I tried a couple some commands works some don’t

Could somebody post the ssh commands to turn off all that crappy services and make it at least sort of usable to us.

We have the ex2 ultra in different setups on different site and all show they same issues. Freezing crashes , very slow data transfers etc… Support is as useless as it could be.


#2

@nicoalbrecht My Cloud EX2 Ultra is a “Prosumer” My Cloud. How are you using these devices at your locations?


#4

Could you be a bit more specific? also prosumer is not a word you either have consumer or commercial business grade ex2 is advertised as business by your marketing.


#5

Are you using these devices as backup servers? File Servers? Hosting Databases on them? Virtual Machines? Etc…


#6

File server only . light users 1- 4 , smb only , all services turned off apart from ftp and mycloud

all 6 units have different setups and are located on different sites , cable based 1Gbit, managed Cisco and Ubiquity switches. 10 - 50% capacity at best , various raid levels , all running the WD reds they came with, all drives were tested for bad sectors . Same issue on every single unit , performance goes ■■■■, to the point were mycloud stops working , no more access to dashboard or it take like 5 minutes to get it and only a hard reboot fixes that. deactivating the scanning services via SSH worked so far on mine but i only found commands for single bay units. If you wanna help provide me with the commands to stop services and to have them turned off. I noticed bad performances and freezing on the second, whenever they arrived a full factory reset and manually firmware update dragged the problem out to start with but it gets worst every week now and times get shorter between freezes.


#7

Based on the discription and without looking at the system logs, it sounds like the My Coud is running out or memory, CPU usage is high of Load Average is high due to disk I/O but I cannot say for certain without having looking at top info and free in realtime. The EX2 Ultra has a Marvel ARM A385 1.2 GHz processor
with 1 GB of physical memmory.

There are only three default scanning services and you do not need SSH access to disable.

  1. Twonky DLNA Media Server should be disabled unless you’re serving meda content
  2. iTunes Server should be disabled unless you’re using iTunes Server
  3. Remote / Cloud Access is required for remove / cloud access, but it will scan, index and generate thumbnails for everything outside of the Smartware and TimeMachineBackup shares. If you disable Remote Access / Cloud Service and reboot, does the issue remain?


#8

Well found the ssh commands and it improved performance and stability massively. New problem that now comes around remote access is not working anymore on os x and windows with the mycloud app . I can access via mycloud.com all data but if I use the app on os x or windows on several different devices it doesnt connect, either loops or i get failed authorized error.