Explorer says file too large but it shouldn't be

I have a 3GB MyBookLive at home that we connect to wirelessly. I"m trying to copy some folders to it from another external, but I get the msg “The file xxxxxx is too large for the destination file system.” However, the drive still has plenty of space. What can I do to copy these folders to it? Thanks in advance for any assistance.


  1. Is the target drive formatted as FAT32
  2. Are one or more files being copied more than 4Gb in size?
  1. How would I tell? When I right-click MYBOOKLIVE in Explorer, Properties is not an option, and when I look at the drive settings through my browser, I don’t see the formatting reflected.

  2. They’re folders consisting of many other folders, from past backups I had done sent to the other external. One of the folders is 12GB+. I doubt any of the individual files it contains are larger than 4GB.

Sorry. It’s a network drive. My questions don’t apply.

In this case find a service named WebClient. Stop this Windows (I’m assuming you’re using Windows as you’ve not stated the operating system) and try again. Just something to try.

Thanks, Myron. Should I have posted this in the Network Drives section instead? The drives that are covered there didn’t appear to include the MyBookLive…

Yep., you need to post your enquiry here:

As to the issue you’re experiencing, a little niggle is niggling me to think that your computer has connected to the MyBook Live using the WebDAV protocol and not SMB, but I;m not sure. on your computer try disable anything to do with being or having a WebDAV client and try again.

I would continue your query in the correct forum.

I just got it to work using the MyCloud software. I copied the files from within File Explorer and was able to paste them into the appropriate directory in MyCloud. This is a new computer, and I’d forgotten about that application. Anyway, the folders are being successfully copied now. Thanks again for the guidance.

1 Like


File Explorer occasionally has difficulty with moving files with long file names, the easiest ways to work around this limitation is to either shorten the file name (Rename the file) or compress the file with WinZip, WinRAR or some other archiving program, give the archive a shorter name you will remember and move the archive to the new drive and then unzip it in the new drive.

These usually work for me.