Experiences, questions and Thank You Myron

Hi All. First post and its a bit of a ramble.

First of, my new MyBookLive 2GB was purchased to replace my old MBWE 1GB (White Lights). The old one had worked really well. It was a new era for me. My first TV that accepted streaming, and the MBWE proved to be a revelation. It was a little slow getting my DVD collection on the drive, but once done, it streamed to my new TV perfectly , even on a “g” wifi connection. Not bad considering Panasonics codec support is not great, and all the movies were in vob format at 4-5 gb in size.

Fast forward 16 months and it was all change. I had run out of space on the MBWE, my telephone exchange had just been upgraded to 20meg, I had received a new “N” router, and my new MyBookLive was ready and waiting. Fortunately, I had been browsing these forums for a while, so I was at least aware that installation may not be straightforward.

Out of the box, installation went great and there is a massive improvement over the MBWE in terms of speed.

I had bought the missus and iPad for Christmas, so I knew the WD2GO app would come in useful. After reading all the advice on here, I enabled SSH.

First question. Can a safely leave SSH enabled.? I have not set any manual settings as such on my router. Is my drive exposed?

I then downloaded the new firmware after deciding to install from file rather than a web update. After much nail chewing, the update went without a hitch, and I was able to log back into the dashboard without fuss. Phew

I tried the WD2GO web access and this also works very well.  Its not what I bought the drive for, but its already come in very, very useful.

Then I tried the WD2GO app on the iPad. This did not go so well. I will explain at this point that networking is not my thing. I am pretty good with anything on the PC side, but when it comes to port forwarding, MAC addresses etc. I really don’t have a clue. I left everything on the router at default (Netgear DGN1000)yet I could only get a relay connection, meaning that photos took ages to load on the iPad. I made sure uPNP was enabled, and at times would get a good connection, then it would drop back to relay. In the end I gave up, and decided to turn on my PS3 for a bit of late night gaming, only to be greeted with a network error and no internet connection. After a lot of messing about, checking settings etc etc, I had to restore my Router back to factory settings to get my PS3 back on the web. No idea what I did wrong, or whether the iPad app conflicts with something on the PS3 side. But something went belly up. I have not tried the app since.

To be fair, I now have a lot of devices that can access the router and MyBook wirelessly. Is it time to start giving each one a dedicated address? Would this help?

To my annoyance I also discovered that the Twonky side of things had also gone belly up. All my photos, videos and music were now all over the place. After eventually finding the 9000 Twonky address (Why move it from the Dashboard WD?) I found that despite setting up the media folders exactly as on the MBWE, media was all over the place and all mixed up. So I rebuilt/rescan the database, which had no effect. In my wisdom, I decided to restart the twonky server. After about half an hour, I got a “this page cannot be displayed” and twonky was gone. !!!

At this point I need to say a massive thank you to Myron.

After downloading putty and following his instructions for removing the corrupt database, I was able to get Twonky to restart. I actually had to do it 3 times as the media was still jumbled up and some of it missing from the database. At the 3rd time of asking, all my media was found, sorted correctly, and streams to my devices perfectly.

My drive seems to sleep OK as well. It does wake up a bit randomly, but when it sleeps, it does so for long periods.

Should I have had these problems? Who knows. The Mybook tries to be a lot of things to a lot of people. Its easy to be critical. But without this forum, and the knowledge I have gained from it, I would have had to send the drive back, and that would have been a shame.

Glad I’ve been of help, but I can’t take all the credit because I’ve also had to learn an have been guided by other members on this community and also W.D. staff.  I just seem to have put some of the stuff together.  :smiley:

Regarding security of the root user once you enable SSH.  The advice is to change the root user’s password.  You do this simply my issuing the . . .


 . . . command then follow the prompts.  Make is a secure password that would be difficuly to guess by a hack-tool that runs past a dictionary of tens of thousands of variations of words.  For example, A secure password for you (obviously don’t use the example I give here could be: ySsuc-1220.05$01

That would take a long time and something that would not work well with a brute attack to gain access to the root system.  Try not forget the password, but if you do the reset button on the MyBook Live will reset the root password back to welc0me and remove the owner’s password.  (User admin)

To me Twonky is a mystery why it goes wrong and also a mystery why you have to erase it’s database three times to ginally get it working, but I guess it won’t the the last time you’ll have to perform that recovery procedure. I have read on the grapevine that W.D. are looking to ditch Twonky altogether hence W.D. are not offering an upgrade to Twonky v6.  I don’t have a clue what they’ll replace it with but Twonky v5 that’s on the MyBook Live certainly has it’s issues.  I’m guessing if some media file has a non-startard header or descriptive information that it may twang a bug in Twonky that causes it to fail.  I recall someone else has to perform the Twonky recovery procedure about 5 times because the media server same up and stayed up.

The other problem, and I sympathise with W.D. on this, is that W.D. also relies on Twonky to sort out the problems with them and I’m also guessing it’s going to cost W.D. a LOT of dollars (many digits before the decimal point) for licencing of Twonky v6.  I would not be surprised if W.D. are also quite peeved with the poor performance of the Twonky media server.

In my honest and professional opinion, SSH should be the first thing that gets enable when the MyBook Live gets turned on when it comes out of the box.  Access to the software guts of the MyBook Live have saved me sending the MBL back to W.D. for exchange.  As you so put, it’s also helped you not have to save your MBL back to W.D. and should it come to the worst where FTP, SMB, AFP, Twonky and iTunes fails, at least it’s possible to back-up all your files and remove them from the poorly MBL to a computer.

There should also be additional checks VERY EARLY ON in the MyBook Live’s process to make sure the Ethernet port it working, that basic Linux networking components are working and that SSH is working.

As precaution, if you have no need for AppleTalk (AFP) on your network then when the MyBook Live boots up, disable this protocol.  Done by . . .

/etc/init.d/netatalk stop

It’ll remain stopped until manually started, the MyBook Live is rebooted or power-cycled.  In which case just manually stop the service.

There seems to be some problem with Apple computing devices and the MyBook Live that communicate using AppleTalk which can cause daemon.log to explode in saze faster than a nuclear melt down and then causing the Dashboard UI to file and all sorts of other things to also fail.

Again, using SSH access it’s possible to fully recover from this situation without having to send the MyBook Live back to W.D. for a swap.

Thank you Myron.

Much appreciated.