Excel documents not saving

Hi ~ new here and fairly computer savy.  Have My Cloud with Excel workbooks saved on it.  When I make changes then save, changes aren’t saved to the Cloud.  Have contacted customer support twice and did everything they suggested.  Can anyone help?  This is extremely frustrating.  Currently I do not trust the Cloud with my information.  

Welcome to the Community.

How are you saving files into your unit? If it’s done remotely please be aware Microsoft Office has some restrictions with regards to remote storage. On those cases it’s recommended to save the actual file into your system, working with it, and then uploading the file back.

Using the “save as” function to save to the Cloud, then when I exit the Cloud software asks if I want to “cancel” “save as new” or “overwrite”.  Doesn’t matter which function I use, data is lost.  Any further suggestions?  Thanks for your reply also.

Does it only happen with Excel?

 How did you setup your folders? private/public what are the persmissions?

Yes, only with Excel.

It happens in both public and private folders.  

WD support said itwas b/c the file was password protected, it happened today on a file that has NEVER been password protected.  

Extremely frustrating.

If you Google this problem, some versions of excel have  problems with network shares as was suggested earlier. Try an office forum to discuss it.

ex: http://www.msofficeforums.com/

try here as well http://answers.microsoft.com/en-us/office/forum/excel?tab=Threads

Thank you for the links, I will check them out.  I have Googled a lot and not come across anyone mentioning same issue/or resolution, so I resorted to the forum.  Thank you.

How do you open and work on your Excel files? Are you on a desktop, laptop, tablet etc.?

When you choose Save As, what is showing as your save location on your My Cloud? Example: Save As>Computer>\WDMyCloud\Jones</font>

Posted by,
cat0w (USA)

Try this, after making changes to your document and clicking on File>Save As>Computer then choose Browse and under Network choose WDMYCLOUD then the Share that you want to save it under and click on Save. You should get a pop up box saying it already exist. To replace it with the changes click on Yes.

After doing this and if it works, in the future you should see the share/location of where you want to save it under Computer. See example image below.

Posted by,
cat0w (USA)

Thanks for both your messages.  As I said, pretty computer savy so I’ve tried saving with the save as/browse as you described.  Nada!  Working on a desktop PC.  I do get the pop up that says it already exists.  I replace it.  Then when I “x” out there is a WD popup that says do you want to save as new, overwrite, or cancel.  Once I press one of these (doesn’t matter which one, I’ve tried all 3) my file goes POOF and is reverted to what it was before I made the changes.  It makes me crazy and a skeptical as to whether I should be trusting this device.  

I don’t know anything else to try. I have Windows 7 SP1, Office Home and Student 2013 on my desktop and I have not had any problems with opening up Excel documents, making changes and saving them. My, My Cloud and desktop are both in the same Workgroup.

Posted by,
cat0w (USA)

Was this ever solved? I’m experiencing the same issue!

I am Having the same issue…