EX4100 & USB Storage attached

Hi folks, just acquired two EX4100 NAS units and so far I am pretty happy with what I need to use
them for. But, I have an interesting issue with one. I have two external drives attached to one(in the back) and at first they were visible on the web access but now I do not see them at all. I have tried powering the EX4100 down and then the external drives. Power up(EX4100) with them detached and reattached them and powered them up and nope, still not there. I have verified that they both are functional and attach to a test PC. They are USB 2 drives both 3Tb with separate power supplies.
The other EX4100 is attached to a UPS via USB and is working fine. Made sure the firmware is up to date on both as well.
Anyone out there have any USB experiences with the EX4100?

Applied the firmware that came out today. Still does not show my USB drives.
I have yet to go through the process of disconnecting them and reconnecting them.
Not sure if it will make any difference but still worth a try.


  • Try with only one USB drive?
  • Try a different USB drive?
  • Swap USB drives between the two EX4100 and see if the issue follows the USB drive?
  • Check this article

External USB Drive Not Seen or Detected by a My Cloud

Answer ID 18918

Yes, 5 drives so far, I have about 12. Working on all the testing you have mentioned, I just got slammed
with other issues from a couple of my client accounts. Had power outages, surges all over the last day or two. One PC totally fried, another HDD fried. Hopefully get back to the testing tonight and tomorrow.

Thanks for the suggestions…
(p.s… I also used putty and got attached and looked at a few things but there was absolutely
nothing there in relation to USB drives.)