EX4100 - New public folders created automatically - many public folders (256)


[REPOST from MyCloud Forum]

Since a RAID rebuild I now have hundreds of public folders (256 to be
precise). The number seemed to double every time I tried to delete

It is very similar to the problems experienced in this post:

I am operating a Mac OSX network, but that should not have caused any
of these issues. I CANNOT take the risk of a system restore deleting
any data. Is there a solution to this? Can I run a system restore with
the drives out of their bays?

Help is greatly appreciated.


Hello, a system only factory restore will not delete the information on a EX4100, however you should be able to perform a system only restore without drives in the unit, but I am not sure that this will fix the issue witht the Public folders.


Thanks Iluna. The real question is how to 1) get rid of the 256 public folders and 2) prevent it from happening in the future.



My public folder count is now up to 512 (it doubles every time I delete a public folder).


Can you back up your data and do a disk format?


Not really, with 8 TB of data. The real question is why it happens (and how to stop it). I believe - not 100% sure yet - that I can remove all drives when the unit is powered down, and THEN do a system reset (not a format).


Is there any solution here ? My PR4100 is having the same problem :slight_smile:

I have 2 disk in raid-1 to form an encrypted volume, and another 1 disk in JBOD mode to form a unencrypted volume.


I wonder what happens if you delete all the “Public” folders, via an SSH session and then reboot the unit twice. I would imagine on the first reboot, it should recreate a brand new Public folder as it would not be found, but could be interesting on the second reboot.

The other concern though would be if you delete it and it does not recreate it.

On my NAS, Public has the following properties:

root@WDMyCloudEX4100 HD_a2 # ls -ald Public
drwxrwxrwx   17 root     root          4096 Jan  1 10:36 Public
root@WDMyCloudEX4100 HD_a2 # pwd




In fact, there is only one Public folder under /mnt/HD/HD_a2/ , but there are 502 Public_N under /shares/ which all are symbolic links to /mnt/HD/HD_a2/Public.

Even after deleting all the symbolic links from ssh, the UI still shows Public_N under Shares management. and at some point, these symbolic links are recreated by the system.

Right now, basically the web UI is almost useless as any share related action just basically timeout, like scan for music, media, etc.


I wonder if these are being stored in one of the config files like the orion database files and then getting created at reboot time. I think there are instructions in other posts on how to check the data in this database, but may be a place to start.


Same problem with my PR4100, soft reset doens’t help. CPU utilization 100%, folders doubles without stop. How to fix? Please help!





Hi! How did you fix this problem? Thank you


I failed fixing this issue, hard reset bricked device, nothing helps me now. It there any way to fully restore from USB?


I’m having the same problem… EX4100


Sorry for my translation, Google Translator is helping me …
I was having the same problem, I called the WD 0800, they asked me for some logs and photos of the problem, I could reproduce it and I sent the problem. But I still have not gotten their return. Not satisfied, I myself went to look for the problem. Until I found how to fix. I backed up files, backed up system configurations … and decided to go back to the factory settings. Settings> Utilities> Restore to default> “system only”. I have not lost any files. Deleted duplicate folders, leaving only 1 folder public.