EX4100 - Does not recognize USB

The EX4100 does not recognize any USB drives after update to OS5.

I have been keeping the firmware updated; including the latest 5.18.117 at the time of this post. I have tried attaching different USB drives to EX4100 ports both in the front and back of the device.
My cloud does not recognize the USB drive. I have USB Backups app installed on my drive and it too cannot recognize the USB drive.

Has any one face this issue? Any suggestions on the settings I can tweak? I have tried enabling and disabling My Cloud access and it did not help.

Kind regards.

try NTFS formatting on the USB drives
but before doing that recheck the USB drive is getting power then re-boot the NAS
( I have ONLY use disk drives that have their own power supply NOT USB powered drives or HUBS )

and try to use the EJECT button in the NAS menu before removing.
the ICON to the right of the bell home page should show any USB units
right point triangle gives more info the up point one will ask if you want to eject.

Thank you. I have tried a Scandisc USB without dedicated power and a Seagate hard drive with its own power; both formatted on NTFS. It used to recognize 8 months back or so and I was actually able to configure the Seagate hard drive to act as redundant back-up.

The Eject button in Menu is a moot point since the USB is not recognized in the first place. Nothing shows up under that menu even when the USB drives are connected.

Thank you again.

you might try a power cycle of the EX after placing it in hibernate then remove power plug wait 10 sec then plug back in the power and wait for the re-boot to finish

if not go - then time to look at the USB disk connected to a computer.

  1. make sure there is only one partition on the USB disk

  2. run a disk check ( I still use the old Data Lifeguard Diagnostic for Windows which has been DEPRECATED and replaced with the Western Digital Dashboard utility )

  3. might try a different USB-3 ( avoid USB extenders cables )

  4. there may be something in the log files that can offer a clue.

hope others can supply more ideas before you have to Enable SSH and Log in directly.

( I have had the USB to SATA interface circuit card fail in WD MyBook external drives )