EX4100 becomes unresponsive, loses network

Out of curiosity, do you have DLNA media server turned on?


I have the Plex application installed on mine from the WD Apps page. I don’t use the Twonky DLNA that comes standard with the unit.



nothing there…
just logs of power loss, since I had to remove the power to reboot it…
This is sooo annoying!!! I am not confident in WD at all now!

2017 Nov 4 09:48:08
System Has Rebooted From A Power Failure.

2017 Nov 3 18:01:49
System Has Rebooted From A Power Failure.

2017 Nov 1 13:19:08
System Has Rebooted From A Power Failure.

2017 Oct 28 13:40:08
System Has Rebooted From A Power Failure.

2017 Nov 4 09:48:09
Power loss detected on port 2.

2017 Nov 3 18:01:50
Power loss detected on port 2.

2017 Nov 3 18:01:48
The network link 2 is down or has become intermittent. Check your network

After advice from WD support,
I did “40 seconds” reset procedure.
I kept the data, but reset the system…after that, I have set up all users again…
So far, it’s been 2 days, NAS is working without any issus so far…
let’s see


Hang after 2 days…


I tried a different tact on this issue. This may have been tried by others, however I just wanted to clarify this.

The suggestion has been to make the IP a static address. I have seen many statements that others have set the NAS IP as static, however it was said that they made the IP reserved. That made me think that DHCP and Reserved was being deployed. That is how I had mine set too and I had continuous issues with the “Lock-up”

I since have changed my Router DHCP range from x.x.x.2 - x.x.x.254 to x.x.x.2 - x.x.x.100. I then set my EX4100 to static and selected an IP above 100.

So far so good.


I’ve always used a static IP Address on my EX4100 and it makes no difference. Yet another smokescreen from WD to try and cover up the real issues the unit has.



OK guys, I’ve resolved my issue with the EX4100. You won’t like the solution but its probably the only one…

I opened a support ticket with WD, described the problem, told them I had been fighting with this since April and I would like to return the hardware for any other WD product of approximate value ( could be hard drives I don’t care ). Just don’t send me back an EX4100 because I’m convinced there is a hardware or firmware problem and its not environmental.

So I did some basic diagnostics and sent them my logs, and at the end of the day they approved an RMA. I returned the EX4100 housing and they replaced it with a PR4100. I reinserted my drives, configured it like before, and the thing has been running for 15 days without a glitch.

So there it is. If your device is under warranty, return it. That’s what they carry insurance for.

EDIT - If you go this route, I have read that you should replace your drives in the same slots you removed them from. *


Mine is out of warranty, plus live in Australia, so would be a pain to get back to WD. I have a work around but the EX4100 is a substandard product and would not recommend another WD NAS product to anyone!.


JediNite, how has your testing on the EX4100 been going since last year? Been a while since hearing from you.


I am still having the same issues with the EX4100 and got no useful responses from WD on the issue. I have the NAS configured so when it hangs it reboots, and for the most part this is okay. I have some VMs that use the NFS share that get unhappy.

I am going to look at getting a different branded NAS in a few months and move the drives from this one to the new NAS.

Hope this helps!


Has your new PR4100 had any lost network problems since this post?
I am thinking of going the replacement route but I am curious if you have had any issues since then.
Thanks for any update.

I forced the link speed to 1000 instead of AUTO and my EX4100 has been running fine without any issues for over 4 days.

I had the same issue. After a month emailing back and forth, they sent me a pr4100 since they were out of stock of the ex4100. It works perfect now. It was obviously an issue with the older ex4100.

Like most others here (i think) , after a whole year and a half i just called it quits and went to the dealer
go a new unit instead, probably should have done that long time ago, i`m guessing some units are just faulty no matter what

Your post was in April - any problems since. Can you point me at the setting for link speed please?

It’s been good.

Thanks. I set mine to this on the morning of the 20th (Nov). Six days later, still running. But we’ll see.


It is now Dec 7 and since changing the link speed to 1000 instead of auto - no problems. However, I did do the latest f/w update in about the same time.

  • bob

I am having the same issue now for several days, is any one from WD is responding here? I don’t really have time for this #!@%