EX4100 0 Capacity with new HD's added


#1

I’ve been running an EX4100 with 2x 1TB HD’s in RAID 1 with no problems.

Couple of days ago I added a further 2x 4TB HD’s. Also set these up in RAID 1 as Volume 2 but after the setup was complete the capacity was showing 0.

Tried again with RAID 0,1,5 & 10 - all with the same result. Smartware depicts the unit with “no writable partition found”.

If I setup the unit as JBOD then I get full 10TB capacity but really want to be operating in RAID 1 for to protect the data.

Any ideas?
Cheers,
Paul.


#2

So you created a new volume, but did you add shares to that volume?

The previous shares you had on Volume 1 will not span over to Volume 2.


#3

Thanks for the reply.

Just tried creating a share and received the error “No Volume Found”


#4

Should look like this try turning off auto rebuild and restart the device then turn it on.


#5

Went into the RAID settings but didn’t have the auto-rebuild option so went back into the RAID setup and once again went through the RAID 1 setup with the auto-rebuild off and then rebooted the device.

Took a few screen shots to show the drives but lack of volumes. Not really sure where to go from here except maybe a complete re-set and start from the beginning.

Any ideas - am hoping that its something i’m missing!!!

Thanks again :slight_smile:

image
image


#8

Your first screen shot shows a pending notification. (Red bell). Is it relevant?


#9

Checked and the red bell is “drive failure”. I think from the time and date code that it relates to when I added the additional two hard drives.

From what I can tell the problem is with the system not recognising the volumes.

Will try and add a few more screen shots - forum wouldn’t allow any further posts before!

image
image


#10

image


#11

Try shutting down reverse the drives (1 in 2, 2 in 1 etc) if you get them back format the drives. You can do this by either changing RAID or by formatting from the menu.


#12

Also try logging in via SSH and issue these commands:

cat /proc/mdstat

And

mount

And

df

Post the output.


#13

Thanks Guys,

I shutdown the unit swapped the drives as suggested and then finally did a system reset. Ran the RAID setup once more and volumes came back!

No obvious reasons for it now working so will run the commands as suggested and see the results. Fingers crossed it’ll just keep working now!

image
image


#14

No Problem; a lot of trial and error gave me the answer.