EX4 locks up after a short runtime

Another reboot required so turning off the cloud services is not the answer to maintaining availability. I will be glad to see the back of the EX-4.

Sorry it did not work… thank for giving it a shot though.

My EX-4 was collected by Amazon today. I decided I’d wasted enough time on it in the three weeks it was here. I wouldn’t be at all surprised to find my reboots had totalled at least 50 in that time. By the end of the second week I’d lost all confidence in the product, so it had to go back. I’ve had many years of great experience with WD fixed and USB drives. Sadly, this adventure did not work out.

After shutting off the Cloud service and rebooting, mine has been running for 6 days, but I’ve noted that it’ll run for about a week before having issues, so I’ll monitor it over the weekend. The WD rep I was working with told me that I was more than welcome to return my EX4 to WD for replacement, rather than dealing with Newegg’s return policy.

An update:

The EX4 was last rebooted 22 days ago, after I turned off the Cloud services. I stress-tested it by copying 3 1/2 TB of data, then deleting it while adding an additional 1TB of data, then starting a playlist while randomly logging into the EX4 admin and playing several files simultaneously off of different computers.

It seems to be holding up. I think WD needs to look into fixing the Cloud service program on the unit.

That’s good news at least! I’m sure they’ll look into it… 

My MBLs work like a champ with cloud access. So far my EX4 does too but I rarely access it (Jinxed myself).

I’ve been stress-testing mine as well lately. It’s been running too well :laughing:  

Question: Does your transfer speed slow down while adding data during the deletion? Minde does and I’d assume that was normal. Just curious!

I didn’t pay a lot of attention to the data transfer speeds, since I was using the server to do the bulk operations, instead of my desktop. I didn’t notice a lag in playback of files off of the EX4 during the operation, though.

My EX4 16TB is now locking up too. Yesterday, I found that I could not get to it from a browser or via the cloud access. I can view the settings on the front panel display, but the device will not talk on the network at all. It would not even power down from the front panel. I pulled the plug, and let it sit for 10 minutes and powered it back up, and it was fine. Now I can’t get into it again. Guess I’m going to have to power it down again. I’m beginning to regret ordering the piece of equipment.

Any help would be appreciated.




How I fixed mine was to pull the plug (hard reset), log into the unit and turn OFF the Cloud Services. That seemed to fix the problem. After running flawlessly for a couple of weeks, I turned Cloud Services back on, with no ill effects. It’s been running since January without any more issues.

Thanks, That is something to try at least. I appreciate you posting that.

I expected more from WD. This should work better than this, and WD should be providing more support to fix these issues.

I worked with a WD tech for over a week to come up with that solution. They assigned one before him, but the first one didn’t even know what model I had. The second one, Salvador, was pretty good once we got all the settings and how I am using mine figured out.

Well, I tried that, but still no joy. My unit still locks up to where I cannot access it with any means.

I pulled the plug this morning, and I can finally get back in, for now. But now, the unit says it is rebuilding volume 1.  So far, I’m not real impressed with this unit. It is offline more than on.

WD where are you? How do I fix this?




I submitted a support request.


I did too.


One of their people will try and contact you, then they will go through a series of tests and diagnostics. That was how they fixed my problem. AsI said, it took a little over a week or so to get it hammered out, and I was on the verge of opening an RMA on the unit.

Thanks. Nothing so far, and it has locked up again. Ugh!

I think the only real solution is to have a firmware update that will make the http server more stable so it does not crash under load conditions or whatever else causes it to crash.