EX2100 no longer shows up as computer in Windows 10 File Explorer

#1

I am not sure if this was associated with a firmware upgrade or a Windows upgrade but I was able to see the EX2100 in File Explorer and then one day it was just in Media and Storage. I have searched the forum and made sure that Windows Feature SMB 1.0/CIFS File Sharing Support was turned on for all the selections. Still no EX2100 under Network.

Any ideas on what else might be causing this? It is only on Windows 10 running WiFi. A Mac Mini attached directly to the router via CAT5 can see all the shares in the Finder. I can also use SmartWare for backups on my Windows 10 laptop and can access the dashboard via a browser.

#2

Hi Stealth57,

You can have a look on below article to access My Cloud on Windows OS:

#3

I had done all those things in the distant past except for changing the NetBIOS setting. I did that and rebooted and still nothing shows up in File Explorer. Many of the images in those instructions are for Windows 7 with some side notes for Windows 10. But, I was able to check all the equivalent entries.

#4

There doesn’t seem to be an easy way to get the EX2100 to show up under Computers, but that doesn’t matter. If it shows up as a Storage Device, then right click and choose Open. Double clicking just launches the Dashboard, but right click and Open actually shows the shares directly.

The only weird thing I found is occasionally, when you select Open, all your open windows are closed and you end up back on the desktop. Second time always works.

#5

Well, the right click worked for a month, but now when I right click on the EX2100 under storage devices File Explorer crashes, the task bar goes blank, and I have to wait a few seconds to be back at the desktop. I never get the context sensitive menu with the Open command. WTF is going on. Why would a right click on the EX2100 cause a hard crash of File Explorer?