EX2 Ultra + OSX (El Capitan) \ Windows 10


I’ve recently purchased the new EX2 Ultra and hope I’ve missed something obvious.

I have set up two accounts which has created a shared folder giving read\write permissions to the respective accounts.
Each account has a password. (although I have tried this without forcing a password)

In OSX, using the WD APP, I go to open and prompted with a login. When I enter the account details all I see are the PUBLIC folders. I do not see the account folder. Any other attempt to connect i.e. drive mapping, produces the same public folders only.

In Windows 10, the account details are not recognised if I want to map a drive. If I browse via the network I can only access the PUBLIC folders. While I can see all folders (including the account folders) the username\password is not accepted.
NB: I can access these folders using the WD app.

Any thoughts appreciated.



I don’t quite remember, but I think there are two main processes: one is the username and password that you already did and the other is only the password for accessing the device(that might help in Windows 10 case). However, I don’t remember how I set that, and I’m not at home right now, you can try finding the way to set it yourself would be great. But I will take a look on it when I have time. Other people might also have better ideas.

Thanks Wutikon.

I can’t see anything obvious but I’ll keep trying things.

I think the password I was talking about is for old firmware, so I don’t have solution right now. But have you updated your firmware to the newest one? Have you tried it using your phone?

Bit strange… But all sorted.

I cleared all my initial additional accounts down in order to show WD tech support via screenshots. When I created a new account with an associated share everything worked as expected.

I’ve now tested on osx and win 10 and both are now showing the associated folders with the account login. Haven’t done anything different this time round.

Whether a firmware update has helped (installs by default) but all now seems to work as expected.

Thanks for your time :slight_smile: