EX2 Ultra OS5 HTTPS redirect not working anymore?

Hi, all of a sudden HTTPS redirect is not working anymore…

Tried rebooting device and still no go…

Whats going on??

Thanks in advance

Edit1: It was working fine since I updated to OS5
Edit2: Don’t know if its a side effect but cannot login to Twonky anymore

@kbzona There are few items that can cause the redirect not to work

  1. Network DNS issue

     To check this, open a command prompt and:
      nslookup download.wdc.com
      nslookup dns.google
  2. System Only Restore

    Takes about 30 minutes or so to get a new cert and the redirect should occur
  3. What router are you using? and does it have DNS Rebinding protection enabled?

  4. Did you set a Twonky Password?
    If not, the Twonky server.ini file could have issues.

I just had the same issue - redirect was not working - I was getting an access denied error - but then all of a sudden it started working again.

Waited 4 days and nothing, did a System Only restore and nothing…

Router doesnt seem to feature DNS rebinding protection, maybe its named differently in router settings?

Now unit started auto firmware update and is stuck in downloading at 0%

All of a sudden it updated to latest firmware, and still HTTPS redirect is not working, and still unable to log to twonky configuration…

Hello, since OS 5 and EX2 Ultra are full of bugs and maybe also security issues as HTTPS redirect never worked again, im considering returning it

Any recommendations of a NAS with similar features and price?


@kbzona the version of Twonky used on the My Cloud does not include a password.
What do you mean by “still unable to log twonky configuration”? Can you please post a screenshot of what you’re seeing?

Twonky is the least of my concerns

I want to know how can I fix HTTPS redirect problem

I tried system only restore, didnt worked , tried another router, and still nothing

Dashboard wont redirect to HTTPS no matter what

@kbzona If you’re getting the Twonky Password prompt, then it means somehow your twonkyserver.ini file is corrupted because the Twonky app doesn’t install with a password. If the twonkyserver.ini is corrupted, then some other config files could also be corrupted which means “Quick Factory Restore” which will format the drives. IE: backup all of your data and perform a “Quick Factory Restore”.

You will get new trusted cert in about 30 minutes after setup is completed which should do the HTTPS redirect. Installing Twonky should also work and not provide the password prompt.

If that doesn’t resolve your issue, we will need more information such as Network Router Make, Model and My Cloud system logs.

I’ve resolved the redirect issue - you need to use the http:// instead of https:// It looks like the https:// results in an error - but http:// will redirect correctly.

Even with FULL FACTORY RESET, did not solve the HTTPS redirect issue

Modem: Arris TG2492LG

System log:

2020 Dec 1 13:28:00 OTHER [ 45.345867] restart sysinfod…
2020 Dec 1 01:33:45 SYSTEM The network link is down or has become intermittent on port . Check your network connection.
2020 Dec 1 01:31:20 SYSTEM The network link is down or has become intermittent on port . Check your network connection.
2020 Dec 1 01:30:53 SYSTEM The network link is down or has become intermittent on port . Check your network connection.
2020 Dec 1 01:30:19 SYSTEM The network link is down or has become intermittent on port . Check your network connection.
2020 Dec 1 07:14:02 OTHER [ 42.903105] restart sysinfod…
2020 Dec 1 04:12:37 OTHER [498268.216380] kill_running_process done.
2020 Dec 1 04:12:29 OTHER [498260.461402] kill_running_process …
2020 Dec 1 04:12:28 SYSTEM The data volume was reformatted on your My Cloud device, and your mycloud.c

Your Arris Router should have Parental Controls and a Firewall. Please check those settings as they could be causing some interference with internal name resolution.
I would also suggest that you contact support and provide your My Cloud System logs.

Both Parental Controls and Firewall setttings are disabled…

Where do I get “My Cloud” system logs???

@kbzona We just did a cloud services push this morning.
Please System Only Restore your My Cloud again.
It’s been my experience that it should get a LetsEncrypt cert in about 30 - 45 minutes after the System Only Restore.

Wow, it seems that the cloud services push did solve the problem…

Dashboard finally redirecting to HTTPS

What to do in case it happens again?


I have a WD Mycloud ex2 Ultra, and i have the same issue.

I System Reset the Cloud… i have the Problem since Os5 :confused:
I try it in Chrome, Firefox, Edge…on my Desktop PC, then i try it on my Smartphone, Notebook from my Girlfriend, all “Not Secure” in front of the Adress.

Firewall deaktivat
I use a Fritzbox 7350