EX2 Ultra - Missing file and folders

So I have a MyCloud EX2 Ultra and I move all my data to it. Not used as a backup, but more as an external drive.
A few days ago, out of nowhere most of my stuff disappeared!
Whole folders are gone. Hundreds of files missing.
No one other than me has access to it and I did not delete all my files accidently…

I tried a few things myself and than called WD support and they had me do a 4 and a 40 second reboot. No change.
Anyone here with a better idea and what happened, why it happened and how I can find my missing data?

Thank you

Is your unit connected to MyCloud and Cloud Access turned on with a strong password? Has the total disk capacity changed if you suspect those files have been permanently deleted? If you’re comfortable with SSH, you could try to login and “cd /shares” and do a “ls -al” to see if the folders and files may still be there but hidden.

At this point I’ll try anything, I have nothing to lose. That said,
I have no clue what you are talking about… SSH…? Is-al…?
Can provide some more details instructions on what it is and how is done?
Thanks

Had a similar problem today. I tried to rename a folder remotely from the browser and it simply gone. There is no way we could delete it from the browser as it has to be done at the page buttons. We have the Ex2 Ultra 4tb RAID for backing up our company files. How come?

Have you found any solution?

Anyone found any solution to this?