EX2 Ultra - Marking Drive as BAD (Predicted Smart Failure)

Okay so this is annoying my EX2 Ultra has decidded to mark Drive 2 as BAD,

These are 4TB WD RED Disks

I have plugged the drive into and external enclosure and Crystal Disk Info indicates the drive is in Good Health, as do a couple of other tools.

I have erased cleared the partition table and erased the disk and once reinserted in the EX2 it became marked as bad again.

I have tested the disk in another NAS by a different Vendor again no issues and the NAS reports the disk is fine.

I have also tried the Disk in Bay1 of the EX2 Ultra and again it go marked as bad, none of the parameters for smart are even close to exceeding the thresholds.

Clearly this device has a very agressive idea of what failure means! (no doubt to force the consumer to by disks they do not really need to buy)

The make you throw it away culture.

Anyone else seen this and know of a way to deal with it without replacing what is clearly not a failed disk

Below are the Smartdata for the “FAILED” quote un quote hard drive.

Personally I am not seeing anything that indicates a genuine failure ?

ID# ATTRIBUTE_NAME FLAG VALUE WORST THRESH TYPE UPDATED WHEN_FAILED RAW_VALUE
1 Raw_Read_Error_Rate 0x002f 200 200 051 Pre-fail Always - 0
3 Spin_Up_Time 0x0027 184 161 021 Pre-fail Always - 5800
4 Start_Stop_Count 0x0032 099 099 000 Old_age Always - 1412
5 Reallocated_Sector_Ct 0x0033 200 200 140 Pre-fail Always - 0
7 Seek_Error_Rate 0x002e 200 200 000 Old_age Always - 0
9 Power_On_Hours 0x0032 081 081 000 Old_age Always - 14161
10 Spin_Retry_Count 0x0032 100 100 000 Old_age Always - 0
11 Calibration_Retry_Count 0x0032 100 100 000 Old_age Always - 0
12 Power_Cycle_Count 0x0032 100 100 000 Old_age Always - 155
192 Power-Off_Retract_Count 0x0032 200 200 000 Old_age Always - 149
193 Load_Cycle_Count 0x0032 199 199 000 Old_age Always - 3478
194 Temperature_Celsius 0x0022 116 090 000 Old_age Always - 34
196 Reallocated_Event_Count 0x0032 200 200 000 Old_age Always - 0
197 Current_Pending_Sector 0x0032 200 200 000 Old_age Always - 0
198 Offline_Uncorrectable 0x0030 100 253 000 Old_age Offline - 0
199 UDMA_CRC_Error_Count 0x0032 200 200 000 Old_age Always - 0
200 Multi_Zone_Error_Rate 0x0008 200 200 000 Old_age Offline - 0

do share your thoughts.

Thanks

It did this before which was when I replaced the disks with the 4TB RED Disks, I was not convinced this time so instead of throwing them out I started looking and conclusioin the disk is fine the NAS is a steaming pile of ! I was considering getting an ex4 i might reconsider now

Does the PR4100 do the same annoying ■■■■ where it wipes out any custom stuff you did over SSH on a reboot like the ex2 does ? I did wonder if there was anyway to get a plain linux os onto the EX2?

Can you point me in the direction of where I might find some info on replacing it with linux ?

Looking on the forum allegidly you can get synology dsm to work on the ext2 ultra lol aswell as debian and openmediavault

The problem I have is the instructions I have just found won’t work as they tell you to install firmware via normal dashboard but I upgrade to OS5 so that does not work with the firmware I found

Yeah I just need to figure out a way to make it cold boot a usb maybe

Oh hang on I think ive got this if I wipe out the mtdblock device this should boot into safe mode and load whatever firmware I shove at it lets try that

Well im thinking that should work for the OS3 image though ? Which is the actual WD Image for this device

I shall excercise caution and await your results :slight_smile: lets not brick a device

1 Like

I’ve had a similar issue with a disk marked as bad. Ran a full diagnostic which I came back to later on, found that the firm wear (5.08.115) had been downloaded and installed to the drive, and then finding that both disks are both now marked as good, so not 100% sure if this is a failure, a predicted failure or simply the older firm wear thinking it was broken?

Cheers

Have you tried installing Synology DSM?

That would be something, DSM seems highly functional and has ‘actual’ apps for most use cases I have. It would be awesome to have DSM on my PR4100 as it has decent hardware and build quality but really shitty software.

Somebody tried it earlier, no sure if it would be useful. DSM is indeed light years ahead of OS3/5 wrt app availability. Also, DSM7 vs OS5 rollout is a good sign of their customer focus.

When about the same happened on Ex2 with a WD red pro 4 TB
I just replaced and used the old disks for other use

One marked bad disk did not pass the Western Digital Data LifeGuard Diagnostic for Windows long term sector by sector test but the other did pass.

Using both still for light duty non critical storage


I too use Debian raid on a old Mac mini to read WD nas drives BUT I also have a WD mybook on all my WD NAS units as a back up and that is easy to read the files.

Hello,

Please refer to the following KBA article: https://support-en.wd.com/app/answers/detail/a_id/22008/