Ex2 ultra dashboard slow - uploads very slow- dropouts

There are many complaints with this same problem. I notice nobody seems to answer most of them. Is this because the machine (Ultra) is no good and I am wasting my time or is it a sniff about network problems. I dont have network problems, I have checked it on ethernet, everything else works fine and fast. The dashboard, there is no apparent reason for it to be slow, it takes so long to load up it times itself out unless I sit there staring at it for 5 minutes plus. After that, all functions have the same delay. I have 300GB of backup and photos on a 4tb machine. Even when all the devices are off the machine is hot and working furiously, what is it doing?
I need a light at the end of the tunnel, it will take me three days to get the files off it to take it back to the shop. I have tried the knowledge base but this is the message I get from Firefox, could I please have somebody help or tell if I need to call support:
Did Not Connect: Potential Security Issue

Firefox detected an issue and did not continue to support.wdc.com. The web site is either misconfigured or your computer clock is set to the wrong time.

It’s likely the web site’s certificate is expired, which prevents Firefox from connecting securely.

What can you do about it?

support.wdc.com has a security policy called HTTP Strict Transport Security (HSTS), which means that Firefox can only connect to it securely. You can’t add an exception to visit this site.

The issue is most likely with the web site, and there is nothing you can do to resolve it. You can notify the web site’s administrator about the problem.

Hi,

You could refer to the following link: https://support-en.wd.com/app/answers/detail/a_id/3534