Ex2 Ultra and Win10 Version 1903

Let me start with: I hate Win 10 Major updates.

SO. . . I have a an EX2 Ultra.
Yesterday, I noticed that after a recent Win10 update on my PC (to version 1903), that I can’t maintain connection to the EX2. . . I can start streaming a video, but it will STALL completely after a minute or two. Won’t restart. Affects VLC, Plex and WMP. Also, I have noted flakey behavior with Windows File Explorer. . . so. . . .SOMETHING is jacked up with the network connection :slight_smile:

I have two Win10 PC’s with version 1903. . . both have this problem.
I have a Win10PC with version 1803 and an Android tablet. . . .both work fine.

I have a MyCloud 4tb. It still works fine with four mentioned machines. So. . .I am thinking Win10 Ver 1903 is where I am jacked.

Any ideas?

(Everything has been rebooted)
(SMB 1.0 is enabled)
(EX2 ultra just upgraded to 2.31.195 (I wonder what THAT will break))
(One PC just got updated video driver, Network card driver. . . .(but that PC has Wifi and access to a second NIC. . .those yield same results).

Gah.

Gah. Still busted.

Streaming to my Win10 (version 1903) PC’s still does not work.
Stream to my Win10 (version 1803) PC is fine.

I have reset everything under the sun in the network configuration of one of my 1903 machines. New drivers. . .ensured all updates installed. . . .reset winsock etc… . .

The interesting part is that while the EX2 Ultra (with latest firmware) will only stream for 90 seconds to the 1903 machines, streaming from my older MyCloud (with v04.05.00-327 installed) is PERFECT.

Yes, I even tried swapping network cables to the two NAS boxes. I opened a support ticket.

Let me continue with: I hate Win 10 Major updates.

SO - - - > I got to thinking: Why does the MyCloud work and the EX2 Ultra not work.
Finally figured out that older MyCloud doesn’t support IPv6, but the EX2 does. . . . So. . . .I unchecked IPv6 in my PC settings. . . . and streaming now seems to now work.

Could IPv6 be the culprit?

Now. . .I am not declaring victory yet.
Need to try the other PCs. . .not sure the best place to neuter IP6 (Router, NAS, or PC’s). But I am back streaming :slight_smile:)

(note: I have not recently tried large file transfer. . . I feared it would have the same problem as streaming)

EDIT added in the evening: : NOW I am declaring victory.
Reset the network settings on the “main” Win10 1903 PC. . . (using Network Reset). Problems returned.
Disabled IPv6 on the PC. . . everything works.
The only odd part is that my other Win10 1903PC is now working even with IPv6 enabled. It wasn’t before. . .

OK. . .I don’t understand, but I can live with that.

Hello, I am facing the same problem, in addition to the loss of connection, I noticed that when stabilizes is very slow.

So - just got 1903 win 10 update? It worked before and now it doesn’t?

These are my steps:

Step 1) reboot everything.
Step 2) update drivers
Step 3) disable IPv6 on pc network adaptor.

Thanks. I did all the steps except to disable IPV6. I’ll try.

I don’t know where to begin for this issue, so I’ll start here.

I’ve had my WD My Cloud EX2 Ultra for about 18months. Worked fine until a couple of months ago and now I’m struggling to keep it connected for even an hour. I have latest update to Windows10, the unit is connected directly to the router by ethernet, the latest EX2 Ultra firmware has just been updated (.195) and I’ve done both 4 second and 40 second resets.

worked for a while and then disappeared. Tried static address but that has made no difference. Sleep option is turned off.

I’m not a super techie but my old HP Home Server is still marching along while I continue to struggle with this product and can no longer trust it.

It sits there will all blue LEDs lit and quietly does nothing after I spend 30 minutes resetting everything.

Before I yank the drives and go to a competitor…has anyone recently got this product to work properly and consistently? If so, please advise a somewhat non-techie user how you did it.

Oh…my router is a Netgear D7000 which is working fine with any other attached devices

Just curious… when it “disappears” from the Windows10, are you still able to access its web dashboard via the IP or is it completely unreachable?

I would contact the WD Support team directly for assistance.
https://support-en.wd.com/app/Contact_Us

No visibility at all even using the IP address. The url page says it can’t reach to address.

I have the system running again now for 24 hours having done a 40 second reset and going through the static ip set up plus ensuring that SMB1 is on (with max set to SMB3). I’m hopeful that with the latest firmware and Windows updates the system will continue to work.

Spoke too soon. The unit has once again dropped off the network and trying to get to it via a static ip address is a no-go.

The unit worked fine until several months ago and now it is no longer reliable. Is it possible to pull the drives and put into another product?

Have submitted a support contact request but am not hopeful for assistance or a resolution. Shame really. I’ve been using WD products for 13 years but this has been a disappointment and I now wonder if I should look to a better product. Any recommendations?

One last question/comment: has anyone managed to get the “Wake this device” command to work when using the WD Smartware app?

I won’t be able to post much until Tomorrow night.

Basic questions for now:
Does this affect all computers, or just one computer?

Did it ever work, or is this a new problem.

Did you try other LAN cables, router ports, or perhaps a different router?

I have done ALL of these actions: cables, computers (only two ever attached in the house), a different router, static ip, 40 sec reset. This all started several months ago and I’m using the latest firmware and up to date windows 10.

It just keeps disappearing while sitting there quietly showing all lights on steady blue.

I have pretty much eliminated the computer and the router. But not the MyCloud unit.

Any thoughts as this is pretty disappointing.

Ok. . . more troubleshooting.

Did you say it “used to work” or it “never worked”?

Are all computers running the same O/S? Are they Win10 machines? (which release? I had issues with the 1903 release a few weeks ago; I had to disable IPv6 in the network adapter of the PC’s to get things to work)

The mycloud unit: Is anything set to do “media scans” or some such? (For Plex, or Twonky, or whatever) Aggressive internal device scanning has been known to cause issues.

Do you have “sleep” enabled on the WD device? (If so. . .turn that off)

How do you get the system back after it “disappears”? Do you have to reboot the PC’s; or do you reboot the router? Or Reboot the NAS?

For Plan B: If you pull the drives; you can “probably” make them work by putting them into another EX2 Ultra unit. Careful. . .as the “defaults” will be to reformat if you insert drives into a NAS box. I suspect it won’t work correctly if you insert the drives into a NAS from another manufacturer.

You can use a USB enclosure to connect the drives to a PC and do a direct data transfer off the drives. The drives are not formatted in a Windows O/S format (like NFTS) and are not directrly readable by file explorer. You will have to use a Linux protocol to make this method work and Linux commands to do the copying. THIS is the best method to get data off a faulty NAS box.

There are other choices for NAS brands. . . .several are good. I am NOT convinced this is a NAS problem, however. It could well be the NAS being flakey. . .but I would not rule out another network problem.

OH - - - - this doesn’t sound like the cause of your problem, but you probably want SMB1.0 enabled on the PC. Some say it’s a security risk. Win10 will disable by default. . . but it “allows” the file explorer to “see” the presence of the networked drive.

(this, however, would not prevent you from directly access the drive by typing \mycloud nor would it stop you from accessing the dashboard from a web browser)

Two other things to check:

  1. Are the devices in the same Windows Workgroup? (easy to goober up). I once had things on different workgroups. . .and that really fouled things up.

2 Are the PC’s and the EX2 on the same IP subnet? (harder to goober up) I know it took fiddling to get the EX2 (on 192.168.0.2) to read a VPN PC on (10.4.0.3). With default settings, the EX2 wants the PC’s and the EX2 on the same subnet (192.168.some number.yyy)

The devices are all on the same Lan within the range if ip addresses. I don’t use a workgroup. This NAS is only used for backups on laptops at this location and for storage of music/photos/videos and misc files. We don’t stream very often from the server.

The only change that seems to be working is shifting back to DHCP from static ip addressing. It is working fine now for over 24 hours. I accept that it may be a glitch in the network interface between the Netgear D7000 and the server network app. If this keeps it running, then I’ll work around having the ip address changed if the power to the router is interrupted.

We don’t access this via remote access for the cloud. So a static ip address is not vital.

One suggestion to the engineers: use your tutorials to show a basic configuration on the dashboard for simpletons like me that only want a storage and streaming server within a single LAN at home. Just a thought.

Finally…36 hours later and it’s all working fine with the network set to DHCP on the router and the EX2 Ultra. So networking is the one factor to consider.

Again…WD needs to consider “out of the box” NAS solutions that simply Plug and Play without all the hassle.

“Be careful what you ask for”

The plug and play solution you are asking for (I think) exists in the MyCloud HOME line of products. However - - - you lose so much functionality in that product that many people don’t consider those units proper NAS devices. For example. . . I believe you require an internet connection for password authentication.

Over the years. . . I have bought three MyCloud devices of various capability. . . .I have found them to have quirks. . .but overall they are pretty straight forward in terms of setup. The problems I see are;

  1. Old software. While what they have works; there are some issues in terms of things like needing SMB and questionable security. Overall, the software is a bit cludgy.

  2. Fundamentally, NAS units are network devices, and the EX2’s are sold as consumer devices. Networks by there nature require three devices to talk to each other. . . .a PC, a router, and the NAS. Try to get anything over the internet. . .and you need to involve ISP issues. That’s a fair bit of IT understanding for an average consumer.

  3. Throw in “apps” (like PLEX). . .and various driver/software updates and its a miracle any of us get the things to work at all.

Part of the equation is cost. The mycloud line is running Linux. The MyCloud Home line is running android. A lot of problems could be resolved if you ran Windows on the NAS box. . .but then you would need more ram, a beefier processor, and a Window$ licen$e.

I understand that there are products with better hardware. . .and products with better software. Those products also cost more. Should we get those? Meh. At this point, I have learned a heck of a lot about networking. . . . so these units are quite functional. My biggest issue at this point is ISP upload speed. . .and that’s not a NAS problem.

Thanks for the clarification…very helpful. The product marketing folks at WD probably need to make a bolder statement of what each product line is used for in general. Linux vs android vs Windows is a techie battleground.

My old HP Windows Home Server in my holiday home continues to do my backups with a much nicer interface but I switched to EX2 mostly down to cost. So I must accept what I get for the money.

My EX2 is still running on DHCP today…fingers crossed!