EX2 shows solid RED on Status front light!

Just bought the EX2 and tried setting it up. Create an account and login. It tells me “Searching or devices”. After a few minutes, it says “My Cloud device not found”
The URL: https://files.mycloud.com/setup it tries to connect.
Shows a list of Trouble shooting tips and says try again.
Power Sold Blue
Drives: Solid Red
Connected to Xinfinity Router and Modem directly.

Please Help.

Assuming you are not having a real hardware problem, try downloading the Fing app on your PC:

https://www.fing.io/download-free-ip-scanner-desktop-linux-windows-osx/

or Smartphone:

https://www.fing.io/

Let it scan your local network.

Then find your WD NAS in the results.

It might be that your IP changed. Once back on, you might want to set it to a static IP.

I was able to scan, and it sees my WD NAS. What do I do next. I’m still having the same issue. No Change.

Write down the IP address of your WD NAS, that you see from the scan.

Lets say it was 192.168.1.77.

Go to your web browser and browse to:

http://192.168.1.77/

I just tried this as I have a similar issue but fing does not identify my NAS, there are connections listed as generic and I have tried to connect to each of these but none will connect. OP did this work for you?