EX2 only the two disk drive LEDs are on (flickering) and the power LED is OFF. lost contact

So I’m about 32 hours into my EX2 experience. It’s not going well.
EX2 12TB Raid1. Unboxed it and upgraded the SW as requested. 07th Oct.
Since I don’t have a gigabit router, I decided to connect my 1TB portable USB drive to USB port 1 of the EX2 and use the backup option to transfer data from my USB drive to the EX2.
I only have about 0.6TB of data on my USB drive.
24 hours later the transfer is still not complete.
I can’t access the dashboard of the EX2. Page times out.
On the EX2 only the two disk drive LEDs are on (flickering) and the power LED is OFF.
USB Portable drive light is flicking.
I can’t access twonky or the DLNA service, EX2 has disappeared from my network.

Should I put in back in the box and get a different NAS drive?
what is going on?

Welcome to the Community.

Where is your unit connected to if you do not have a router? Are you able to access the Dashboard by typing your unit’s IP address in an Internet browser?

I have a router (10/100) connected to my EX2, i don’t have a gigabit router.
I knew my router would be slow, thats why i connected my USB portable drive to the USB port on the EX2 to transfer data from my portable drive to the EX2.
yes, i’m trying the IP address into the my Internet browser. Yes it worked before i started the transfer of data, I have had no power outages hence the EX2 should have the same IP address. Sometimes, i can get to the EX2 login page (after a long wait) but no further.
I have not given my EX2 a static IP address, Can’t see why i should, unless their is something wrong in the SW.

fireware of EX2 is 2.10.302

Not a great start to my EX2 experience. I hope i didn’t make a mistake in purchasing this product.
So far i can’t backup my data to the EX2.

On my Cloud Mirror Gen2 the power led is not working, regardless of booting or normal work. But my cloud is accessible and everthing else work normal.