EX2 Backup Issue

I’m having an issue running an rsync backup of my EX2 NAS to an external USB 4TB Seagate drive. Up till now it’s been working fine. I’m on the same NAS FW ver as before, 1.05.36.

I connect the external drive, and there is disk activity for about 10-15 minutes on both the NAS and the external. I don’t recall if this activity was always the case before or not. Running top I see wdnotifyer running, taking > 20% cpu. While waiting for this activity to end, I get tossed out of putty with a “Server unexpectedly closed network connection”. If I try to telnet back in I get “Connection Refused”. Similarly, I get tossed out of the dashboard, and can’t re-connect, also connection refused. Shares still respond at this point, but to be able to telnet in again, I have to pull the power to reboot.

I’ve tried other USB drives without a problem. I was able to backup my external 2TB photo drive to the NAS via rsync. All this is over local network.

Any thoughts why the NAS is having an issue with the 4TB Seagate drive?


Make sure that the unit that you are connecting is formatted on a supported file system.

 NTFS (read and write capability)
 Linux Ext2, Ext3/Ext4

Also, try resetting the EX2 and test that again.

Hi ERmorel,

Thanks for the reply. I’ve been using the ext drive as is a number of times before with no issue. It’s NTFS. And when I connect the ext drive, and the EX2 won’t allow a telnet or dashboard session, I have to pull the power and reset it to get it back. I’ve tried this about 4 times, always with the same result.


As a recommendation, contact WD Support for direct assistance on this case.

WD Support:

I’ve experienced the same issue with a 1TB HD with NFTS filesystem, after 2 weeks testing the NAS hangs up with the NTFS filesystem, so I switched it to EXT4 and now works as a charm, so I guess it’s a problem with the current firmware and NTFS filesystems.