Ethernet speed bug


#1

I have an older Cisco 2900 Cat switch as the center of my home network. Anyone that has worked with these knows that auto-negotiation of Ethernet speed does not usually work with this switch - so i have all ports set to full duplex 100 Mbs and I do the same with my PCs and other hardware - I  manually set them to 100Mbs full duplex.

The WD TV Live happily connects like this and Internet vids play fine. But local network vids would all hang after 5 seconds, shares would take a minute to enumerate, and the box would reboot with fatal errors.

Changing the port to Auto-negotiate on the switch solved my problems - took a while to figure this out as my WD passport drive stuttered too; finally a Corsair thumbdrive worked so I knew the box was OK.

WD should add a menu option to view the Ethernet speed and flow even if they don’t add a way to adjust it.

Hopefully this will help someone else that has poor network performance.

WD - if one end of an Ethernet connection is set to 100 Full, the other end should Auto-negotiate - the WD box is supposed to handle both speeds so it should Auto Negotiate if the other end is hard set.


#2

WD - if one end of an Ethernet connection is set to 100 Full, the other end should Auto-negotiate - the WD box is supposed to handle both speeds so it should Auto Negotiate if the other end is hard set.

… The WD DID autonegotiate, and from what you’re describing, it did it correclt,y too.

If one end is hard set, the correct behavior is to match speed and set duplex to HALF.   

In other words, if your switch was hard set to 100/FULL, the WD would have set itself to 100/HALF.   If you disable auto-negotation on one end, the far end cannot determine the DUPLEX configuration; it can only sense the speed by detecting the Carrier “Link Test” pulses or Fast Link Pulses.

That’s probably why you were having poor performance;   one end FULL and one end HALF is a disaster in network terms…  Collisions aren’t detected and the resultant corrupted frames are interpreted by the receiving device as a Runt/Giant/ or mal-aligned packet, or will fail CRC checking…  And since the collision wasn’t seen by the sender, there won’t be a retransmit until the application requests it.

Exactly what model of Catalyst 2900 is this?   I’ve been continuously certified CCNP/CCDP for the last 12 years, and I’ve not come across ANY switch where “auto-negotiation of Ethernet speed does not usually work.”


#3

I always thought duplex was negotiated along with speed - I will have to review the protocol.

I too have been certified CCSP and CCNA for many users - and I have had Cisco switches consistently fail in auto-negotiation so that collisions go through the roof due to duplex mismatch - I have always hard set on switch for this very reason and I hardset on server/device when available.

I am talking the 24 port switches - 2900

EDIT:

So Autonegotiate does support negotiating Duplex mode, but if one end is manually set to full, the other end will incorrectly not detect and be at half-duplex - creating collisions.

So, i guess it is not a bug, but the device should at least offer to display the settings.