Ethernet port died


#1

The Ethernet connection port of my WD TV it’s suddenly completely dead.

The united worked perfectly for 6 months, and suddenly the other day when I turned it on I realized it couldn’t connect to YouTube. The automatic network configuration does not work and says that it is unable to obtain an IP address because the player has limited or no network connectivity.

I have  checked the cable and the router and both work normally with my netbook.

I have done a Hard Reset, a Reset to Factory Defaults and a Power Cycle (aka ‘Pull the Plug’).

The weirdest part is that I have noticed that none of the leds of the network connection lights up anymore. Its like if the Ethernet port died. They only light up briefly after you turn on the device, but just for one second, and then nothing.

I have the latest official firmware, and it worked perfectly for more than a month, and then this happened. 

Any ideas or suggestions?


#2

Welcome to the forums.

If you’ve plugged your network into the same cable right where the Live is and it works with your network just fine, then pretty much sounds like you need an RMA (to get the unit repaired or replaced).


#3

To start the process:  http://support.wdc.com/warranty/index_end.asp?lang=en