Essentials 1TB unknown device


#1

At work we have bought (a while ago) a My Book essential 1 TB. But when I connect the drive (windows 7 x64) it’s trying to install the hardware but it fails.

Now it’s listed as an “unknown device” in the device manager.

Tried everything that I could d/l from de wdc site but nothing works. I have the feeling I need the WD ses driver  for it to work, but it’s nowhere to be found.

The drive is (of course) not listed in de drive manager.

Is there anything I can try or is it a DOA?

For as far as I know the drive has never been used, someone connected it once but needed admin rights to install it, it was disconnected after that and now I’m trying myself (@ home so no account restrictions)


#2

Well so far for patience… :slight_smile:

I dismantled the enclosure, and after a thurough investigation i noticed two tiny little pins on a smd part (thank you magnifier) that were a little bit to friendly. Tried to bend them with a needle to no avail, 'cause i pried it of the circuitboard…

Bye bye My Book

Hello sata disk in my HTPC… :slight_smile:


#3

You didn’t mention the specific model of My Book, but for recent products the driver is located on the virtual CD drive that appears in My Computer when you plug in the My Book. 

If you disabled the virtual CD using WD’s SmartWare Virtual CD Manager, then the CD drive will not appear in My Computer.