Essential 2tb worked on usb 2 but broke on usb3

Not sure if this is a drive or pc/motherboard problem.  Anyway this has happened on 2 WD Mybook Essential 2tb drives now.

Using windows 7 ultimate.  The drive worked fine on a usb 2 port, windows picked it up, installed drivers, everything was fine.  I the plugged it into the USB 3 port and windows didnt pick up the drive.  not only that but when i plugged it back into the usb 2 port that it was working on 10 seconds ago, the drive isnt recognised.  And it no longer works on my other PC (Windows 7  pro) or my laptop, again windows 7.

Going into the Manage window and refreshing drives doesnt pick it up. Uninstalling the USB root hubs and rebooting and reinstalling usb drivers doesnt pick it up.  The drives are to all intense purposes, dead.

Same thing happened with both drives.  Is there an issue with this drive and USB 3? I see a lot of people having trouble but at least theirs worked when plugged back into a usb 2 port.

Any suggesstions of what i can try to either say for sure its the drive or the usb 3 card blowing drives up?

Thanks in advance.

EssexAsh, maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support