eSATA disconnect after sleep / Win 7 64bit / MyBook Studio II

I recently bought a new computer and experience since the beginning disconnects of my eSATA drive (WD My Book, 2T). This usually happens when the drive powers down due to inactivity and is reactivated again through Windows. When trying to access it, the drive is disconnected.

I tried several solutions already:

  • all drives (MyBook) tested -> fully functional, Tested all drives seperately and also combined as RAID over USB

  • Latest firmware installed for the MyBook Studio II (2TB)

  • latest Bios for the P8Z68-V Pro/Gen3 installed -> 3202

  • AHCI activated in Bios and installed in Windows 7 (64bit). Was active when system was installed the first time.

  • latest JMicron drivers installed from manufacturer’s homepage JMB36X_WinDrv_R1.17.63_WHQL_eSATA

  • latest Intel Chipset drivers installed V9301019

  • All Windows 7 updates done (including SP1). The hotfix http://support.microsoft.com/kb/977178/  should be integrated in the SP1 and could no longer be installed.

  • I did not update the JMicron Bios but I guess this is done with the BIOS updates automatically

I used this external drive over years (with Win 7 32bit) and it worked without any problems. If I connect it via USB it powers up from sleep without any problems. Only when I connect it via eSATA it disconnects after sleep, but until it goes to sleep it works without any problems. I yesterday copied 300GB without any problems. Only the power up via this JMicron controller is not working. If I reconnect the drive to my old computer via eSATA it works like a charm.

I read many things. That this could be Windows 7 respectively 64bit related. Also that it could be controller related, also that it could be related to the controller of the MyBook etc. No one really knows how this is really solved but many people seem to have this problem.

My system configuration:

  • Intel Core i7 2600K BOX, 3.4GHz, LGA 1155, 4C/8T, unlocked
  • Samsung SSD 830Series D-Kit, MLC, 256GB, SATA-3, 2.5 Zoll
  • Lite-On iHBS212-32, BluRay-Brenner, schwarz, SATA, Retail
  • MSI GTX-560 Ti Twin Frozr II/OC 1GB GDDR5, PCI-E 2.0 x16
  • Alpenföhn CPU-Kühler Brocken - AMD/Intel
  • Kingston HyperX, 4x4GB, DDR3-1600, CL9-9-9-27@1.65V
  • be quiet! STRAIGHT POWER, E8 CM 680W 80plus Silber
  • Asus P8Z68-V PRO/GEN3, Z68, LGA1155, PCI-E 3.0, SLI/CFX
  • Seagate Barracuda 3TB, 7200rpm, 64MB, 3TB, SATA-3
  • Cooler Master Silencio 550 RC-550-KKN1 Midi Tower, black
  • WD MyBook Studio II 2 TB
  • Windows 7 64bit SP1 Professional

Thank you very much for any help you can provide

Alex

you can install Drive Manager

also, check if the Esata power settings can be adjusted…

Seems to me it stops sending power while on hibernation and that’s why the drive will not resume at all

you can install Drive Manager

-> I have done this, this did not bring any change

also, check if the Esata power settings can be adjusted…

-> I could not find these power settings in the BIOS or in Windows. Can you tell me were to look exactly?

Seems to me it stops sending power while on hibernation and that’s why the drive will not resume at all

-> could be. The drive has external power but when in sleep, if cannot be waken up via esata.

Thx for further help

Does anybody have further tips here. This problem seems to be difficult for many people. I would really appreciate further tips.

Thanks a lot and best regards

Alex

dude try checking with the computer manufacturer for updated drivers with the Esata controller

verify if they have any information about a similar issue and a work around

I have a new My Book Studio Edition II 6TB on eSata with exactly the same problem. None of the Western Digital softwares is compatible with this drive on eSata connection. Please let me know if you have find any Western Digital or other 3rd party softwares which is compatible with this drive.

Warning: if you are looking for an eSata drive, try to keep clear of Western Digital. With numerious conversations with Western Digital technical support, they said that they are aware of the eSata problems related to their drives and they have stoped production of any eSata devices.