Errors when trying to clone a disk

I am trying to clone a WD disk (250 GB) with Acronis True Image version 2010.

However, the clining fails due to to errors on the disk.  I ran CHKDSK /f which corrected several errors but my attempst at cloning still fail.  The S.M.A.R.T. analysis (made with EVEREST) does not show anything abnormal and I can still use my disk normally.

How can I clone that disk ?

I whish to clone it because it contains many programmes and it would take me a lot of time ig I had to install windows and all those programmes manually on a new disk…

Hi, are you trying to clone the hard drive to another internal HDD or to an external? If you are using an external is more prone to fail.

Thank you for your reply.

Yes, I was trying to clone to another internal HD.

Actually, and since I put this post, I found a practical solution: I use XXclone (from which actually clones disk NOT sector by sector (as Acronis and most other cloning utilities) but simply by copying file by file (and also transferring the MBR and what is needed to make the new drive bootable.  XXclone will copy all files while ignoring those in which there was some error.  Fortunately, most errors were in data files, so I  only missed a few files (but could recover them from a previous backup).

At the end, I got a nice clone that works. 

The only SERIOUS downside is that the process took VERY long (about 25 hours) to opy all files (about 200 GiB).