● Error on saving directly to G-Drive Armorlock SSD Sandisk Professional

I am reaching out to this forum as western digital support does not seem to understand the issue nor the root cause and the appropriate solution. They completely miss the point and are way off mark.

I have purchased 2 G-Drive Armorlock SSD Sandisk Professional

When I create HDR .DNG files via Adobe Camera RAW (15.0) and in saving the picture directly unto the G-Drive, I get an error message “Could not save x because of a disk error”

I can save the HDR .DNG file on my computer and THEN copy it over to the G-Drive. I can retrieve the pictures from the G-Drive no problem. It is saving DIRECTLY to the G-Drive that is my problem. I am experiencing this issue with both of my G-drives.

I have also tried with Photoshop and Illustrator and I am having the same issue/error message. So the issue does not appear to be because of the specific file type I am treating nor Adobe.

I don’t know if it is related but it seems that this correlates to the time I did the last firmware update of my external drives.

Another thing that might be the cause is I recently changed cameras and the .RAW files are usually around 300MB.

N.B. I have also noticed that there is a folder called “damaged files” and there are currently 3 files in it (out of a thousands). I know it’s not alarming but I am wondering if it is a cause for concern given what I have described above.

Hi @DimitriC,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting:

Hello Keerti_01,

I’ve already tried explaining my issue to support and after 5 attempts, I gave up. They are always off the mark. (last response I got was that my drive is faulty and reverted me to recovery companies)

That’s why I’m reaching out to the forum.

But no feedback so far :slightly_frowning_face: