Error message when trying to register for mycloud.com

I’m about to give up on this product. I mentioned before in this forum that I got error messages during installation. I’m now trying to register for mycloud.com from the mycloud setup program. When I click the register button I get the following message (freely translated): Error - Your last action timed out. Verify that there are no problems with your network connection and try again. post_device_user_500. I’ve tried deactivating the Windows firewall but to no avail. I run Windows 10. Can someone from WD support contact me please or I’m taking this thing back to the dealer.

This is mostly a user to user support forum. You may want to try contacting WD Support directly if you have not done so already.

http://support.wdc.com/contact.aspx

1 Like

I have emailed WD support. Let’s see what they say. There are so many things not working with this thing there’s obviously something wrong. I suspect it’s related to network communication. I can however see and access the device from Windows explorer so so far so good.

More than likely, it’s an internet issue, the drive cannot communicate to the outside world. Your intranet, within your LAN, is okay. Without proper internet connection, it can’t register, update local time, or check for firmware. Try checking the time and firmware version to see if an update is available, if neither are working, then it’s internet. The most common issue is DNS address issues. You can try setting the MyCloud to a static IP and use public DNS addresses like Google.

I could actually download new firmware so it can access the internet so far it seems.

If it is new, and has no irreplaceable data on it, I would recommend a Quick Factory Restore and then a clean setup using the Dashboard, NOT the automated setup program.This controls the device directly, rather than adding another potential source of error. And you will learn much more about configuring the device.

I’d also recommend leaving it as DHCP,. and usng your router to set an infinite DHCP lease timeout for the MyCloud.