ERROR: Media server database internal server error. (400162)

I have recently ran into this error message when connecting to My Passport Wireless via wifi and logging in via my browser.

Is there any way to fix this?

I am unable to access any media that was loaded on the drive and when I connect it via USB to my computer, it asks me to format my drive.

My drive was working fine until I connected it to my TV via USB and watched some videos.

The device is running the latest firmware v1.03.13.

Any assistance would be appreciated, thanks.

Hello there and welcome to the WD community.

Does the same issue happen when you connect the unit to a different computer. Also Try to reset the unit by pressing the WPS and Power buttons for 10 seconds. Hope this helps you out. 

If you try a MPW Reset, as per the manual make sure the MPW is ON before you initiate the reset by pressing the WPS and Power buttons for 10 seconds. Otherwise things can go badly wrong.

But of more concern is that your PC asks you to format the drive. That usually implies some corruption of the FAT and/or the boot sector. You may be able to fix that using CHKDSK on the PC, with the drive connected via USB. Otherwise there are plenty of utilities to fix drives, even some from WD.

But before you do anything, if you can you should try to back up the media off the drive to a safe location, as you may lose it trying to fix the drive.

Note also that there is a Media Database Rebuild button on the Media tab of the MPW web interface that may fix the specific error that you saw. But you probably need to address the hard drive issues first.

@ RoderickGI 

Your pointers are good ones, and I will add that someone recently said a neighbor’s TV formatted his MPW rendering it useless.  My guess is the TV was likely looking for a drive formatted as NTFS, and since the MPW comes formatted ExFAT that may have caused the TV to go bonkers on the drive.

These kinds of issues cause me to say that there are so many other ways to get video on a TV instead of connecting a HD directly to it, that I would avoid doing so.

Thanks for the tips all.

Neither seemed to have worked (I tried the rebuild a few times).

Drive is working now after a full reset. I was lucky that the data on the drive was replaceable. When I use it for travelling to store photos etc, I’ll know not to plug the drive into anything other than a PC.