Error: Local device is disconnected (when playing any movie)


#1

Hi, I started receiving this error yesterday evening.  Any video that I play on my WDTV LIVE now plays for about 20-30 seconds at most and then kicks back out to the file selection screen and then displays this error:

 “Local device is disconnected”

I’m using a WD Passport Elite and have used this for over a year with no problems.  I had played 2 full movies yesterday afternoon with no problems and then yesterday evening when trying to play a movie, I got this error.  I tried multiple times with that movie and same result.  I then tried playing other movies including ones that worked successfully yesterday afternoon and got the same error every time.

I’ve also tried using both USB2 and USB1 ports and have tried connecting the Passport directly to the WDTV Live rather than in its dock as I usually do.  All had the same result.

Lastly, I’ve reset the device with a pin in the side reset button and reset to factory settings…same result.

Any idea on this?  I plan to try a different hard drive in case that’s an issue but I know that hard drive is at least functioning as hooked it up to my computer and was able to view and transfer files fine.

Any thoughts on what could be causing this?  Thanks for any assistance…

UPDATE: Just tried connecting my Seagate Freeagent portable hard drive and it seems to be playing fine so far.  So, looks to be related to the hard drive even though the hard drive works fine when connected to my computer.  Anyone had this happen before??  I suppose I’ll try reporting to WD Customer Support to hopefully find some resolution.


#2

Have you scanned your drive from errors, if you are not getting any issue with another drive, as you stated, then your WD might have errors.