Error Creating Safepoint

Hi - I have a Live Duo 4gig on my network and have for the time being disabled everything except for the file server.  I have the latest firmware as of 3 days ago when I purchased the drive.  I have twice attempted to create a safepoint to a DNS-323 NAS with all its’ services disabled.  It contains 2 1.5TB drives in JOBD configuration.  The backup starts, goes until 100% with around 30mb to go, then fails.  I get the "There was an error creating your safepoint Safepoint on the Volume_1 share on DLINK-41A1DA6 (the default name for the DNS-323). I have a gigabit ethernet network with mixed macs and windows machines.  I have not been able to find any tips that have worked on this board so wondering if one of the support folks have any ideas how to get it successfully backed up.  I am backing up around 500 GB of data (which makes testing out different ideas a lengthy process considering it takes over 24 hours to do the backup).  Thanks!

For direct support from WD I recommend you to call or email tech support diretly, but you can first try to powercycle the my book. Check the link below for a list of supported NAS that you can use, you can also connect a USB hard drive directly at the my book to complete the backup faster.

I’m currently using the support tool.  I had already tried attaching a 3TB usb drive but same problem there as well.  Tried to run drive diagnostics but the long test hung at 90%.  Sigh.

Has anyone else run into this problem?  Any other ideas for solutions?  Thanks!