Error -36

I am attempting to transfer pictures and video from my Mac to my WD Passport 320 gb. I can drag and drop folders, but after its loads a few pictures it pops up with Error -36. It then disables any use of my hard drive and I have to un plug and re plug my passport into my computer to access files again. Is there anything I can do to make it transfer video and pictures painlessly? Has anyone had an experience like this? 

What drive is it? There are several 320GB Passports so the full model number is a must. Also, what version of OSX is your Mac running?

what file format are you running?  have you been transferring files between windows and macs?  have you been just pulling the cable after transferring data? 

sorry, I wasn’t meaning to be a smart aleck.

The product is a mypassport essential. Serial number [deleted]. I always eject it before unpluggling the hard drive. Ive had this for over a year. I dont transfer stuff on it very often, I will need to over the next few weeks while I am traveling and want to be able to dump video on it everynight without issues. Its does it with JPG and with MOV files. I am running Mac OS X 10.6.8 on a Mac book pro with 2.16 GHz Intel Core 2 Duo for a processor and memory of 1 GB 667 Mhz DDR2 SDRAM. Not sure if all this is relevant but i figure the more info the better eh. 


And I have only been plugging it into this Mac. Never into a PC

Here are a couple of things I found concerning error 36:  the first deals with samba password error.  that’s a network error.

based on the second link, you have an I/O error.  that could mean you need a new usb cable, but nothing more than 18 inches long.  or it could be a bad port on either the drive or the laptop.

sorry no dice still get the error code. I have updated the software and removed the password and still get the error along with trying ever single USB port on my computer. I have a hard time believing they are all corrupt yet still work for other devices. Any other Ideas, I really dont want to reformat the drive because im not convinced that it will help me. I dont have the ablility to back up all the files on the harddrive so anymore ideas on anything?

also everytime i eject the disc i have to force eject it. Even when I plug it in adn the first action i take is to eject it, the computer makes me force eject it. I am leaving on friday and cant buy a new one before the trip. I will be so grateful if someone can help me to figure this out. Thanks. 

What if you try to use Disk Warriror for data recovery before you format the drive?